I see lots of questions about recovering data from corrupted SD card formatted as internal storage, that's not my case. I want to FORMAT this SD card to be able to use elsewhere.

For some reasons the card become read-only so it is impossible for me to make any changes. While on the phone I tried to switch the card from internal memory to external. It didn't work. The only option I had was to forget the card, and so I did. Now even with gparted on linux, I'm not able to format the card. I tried also to change the permits with

sudo chmod -R 777 /dev/sdb

and other different commands like

sudo mount -o remount,rw /dev/sdb

all without luck.

What else can I do? It seems impossible to reset this card.

Ps. the lock on the SD adapter is in the correct position

edit1: I've used sudo badblocks -wsv /dev/sdb no errors found, but not luck, the partitions are still there (here how to use badblocks https://wiki.archlinux.org/index.php/badblocks). The process took around 10 hours for a 64Gb card.

edit2: after asking help to bunsenlabs.org these things came out. At the moment I can't try them because I don't have the hardware required but my gut and my common sense tell me that it's the right path.


  • Try sudo mount -o remount,rw /dev/sdb
    – Bo Lawson
    Commented Jun 12, 2018 at 20:46
  • @BoLawson I already tried that, added to the question
    – overkill22
    Commented Jun 12, 2018 at 20:55

2 Answers 2


It sounds like the other answer of the FAT being corrupt is likely, I would try "zeroing out" the card...

First, verify the device. It will be something like /dev/sdX or similar, make absolutely sure you know this device is correct. Then, in Linux open terminal and enter the following command:

$ sudo dd if=/dev/zero of=/dev/sdX bs=8192

Substituting the correct device name for /dev/sdX.

DO NOT interrupt this process or it could possibly brick the SD card.

Once it has completed, eject and remove the card. Wait a few seconds then reinsert the card in the card reader. After this, open gparted (or your partition manager of choice) and create a new FAT and partition. In gparted, this is accomplished by selecting Device, then Create Partition Table from the toolbar menu, I would recommend using msdos as the partition type. Then after that process completes, select Partition - New, and change the File System to fat32 (or whatever is appropriate for your card) and click Add. Then Apply (the "return" arrow in the menu bar).

Once this has been completed, remove the card and reinsert it, it should be readable in Linux, Windows, and most other operating systems.

  • I followed the step but like last time, it didn't work. The dd process finish, but gparted still see the two partitions. If I format with msdos the process end with no errors, but then the sd card refresh with the same old partitions. Trying to do different operations or using different file systems doesn't change anything.
    – overkill22
    Commented Jun 12, 2018 at 21:49
  • I don't know what to do anymore if even dd is not working.
    – overkill22
    Commented Jun 12, 2018 at 21:57
  • @Alessio We have definitely seen corruption of adopted storage nuke a card... I guess becoming permenantly read only is a possibility as well.
    – acejavelin
    Commented Jun 12, 2018 at 21:59
  • how can a card become permanently read only??? The card is working perfectly as I could backup all my stuff and etc, it's just I can't do anything now because it's in read only mode. There must be something to do.
    – overkill22
    Commented Jun 12, 2018 at 22:05
  • @Alessio I don't know, but I had a USB thumb drive do it once... I wound up breaking it and throwing it away because I could not get the data erased.
    – acejavelin
    Commented Jun 13, 2018 at 3:10

That sounds as if the FAT might have some kind of error. The card automatically gets mounted read-only, and no matter how many times you go into settings and try to unmount/remount the card, it is to no avail.

In Windows, you can just insert the card into PC, right click on its Properties/Tools/Check and check it against possible errors and automatically fix them. Or you can also use any file system checking tool of your choice.

  • didn't work. before checking for errors is asking to format the card. formatting the card is not possible because of some errors.
    – overkill22
    Commented Jun 12, 2018 at 21:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .