1

I'm hoping someone can save my sanity here.... I'm trying to install a new firmware on my daughter's old Android device - a wonderful Doogee X5 Pro. I really want to install some new firmware as this device is one of those that's sold on Amazon that after a week or two of every factory reset gets unwanted adverts popping up all the time.

When I hold volume down & power I get to a "factory menu" but the recovery option isn't there. When I hold volume up & power there is a recovery option but all I get is the android on his back and the phrase "no instruction". I have finally managed to get that ADB stuff installed but that tells me the server version doesn't match the client...

I have tried SP Flash thing but I found the whole process very confusing and it didn't work. I've tried a couple of rooting programmes off the internet but they both failed.

I have a little recovery file ready that if I can get to it via recovery will root the device and allow me to install what ever I want. I have two firmwares ready to rock & roll....

So if anyone knows how I can get the recovery option back on the factory screen or resolve the issue in ADB I'd be very, very grateful. Or point me in the direction of a website with instructions on either.

Apologies if this sort of thing has been posted many times before.

Thanks,

Ross

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.