0

When installing the Xposed framework do I need the device specific binary (like custom recovery or ROM) or just the app that works for Android (4.4.4 in my case). The device is Galaxy Tab E T560.
Update 12/7/2018
I tried to Install the framework as on the custom ROM as well as on the stock firmware but with no luck. It seems that Xposed is device/arch/firmware dependent.

  • To my knowledge, there are no device specific builds. It just needs to match the Android version. Worked that way for me on multiple devices for years. – Izzy Jun 19 '18 at 6:46
4

Built for the Android version, plus the device architecture (arm/arm64/x86). See the Xposed Framework download page (e.g. Android 8.1 (SDK27) here).

The reason behind this is that part of Xposed Framework is a modified app_process binary (Zygote), which is different for each arch.

  • Hi! Thanks for the info. I heard that you must find the correct one and flash it via twrp. I am also downloading many versions for my T560 (Lineage OS) and cannot install any xposed app with Unknown sources set to on. – S4NNY1 Jun 19 '18 at 13:31
  • If you're rooted then you can also use the Xposed Installer app which should automatically find and download the correct stuff for your Android version and arch. What you described sounds like another problem entirely. – Andy Yan Jun 19 '18 at 13:40
  • I am getting this error: Xposed is not (yet) compatible with Android SDK version 19 or your processor arch. ( armeabi-v7a). CANNOT LINK EXECUTABLE: cannot link symbol "ZN7android14AndroidRuntime5startEPKcS2" referenced by "/data/data/de.robv.android.xposed.installer/cache/app_process". The device is also rooted with Chainfire SuperSU – S4NNY1 Jun 19 '18 at 17:59
  • @S4NNY1 Android 4.4? You'll need an ancient version (e.g. 2.6) of the installer. – Andy Yan Jun 19 '18 at 22:04
  • Every damn version I try, the Install button is disabled and the error remains. – S4NNY1 Jun 21 '18 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.