0

Up until a couple of hours ago I have been able to view my internal storage and SD storage on my phone when I connect it to my computer via USB. I simply swipe down on my phone, click USB for file transfer and select "transfer file." Since formatting the SD card I can view my SD card storage but NOT my internal. Should I still be able to see the internal storage after I do that?

enter image description here

Other than formatting the SD card, there are a few things that I did to my phone since being able to view internal storage:
1) I moved some apps to the SD card
2) I activated/enabled developer options (sorry I did that) but nothing is changed, that I know of
3) I cleared the settings storage cache (not data)
4) Some apps updated but I don't know which ones, I didn't pay attention to the notification

I'm not sure which, if any, of these things would cause me to no longer be able to view my internal storage.

I tried:

  • restarting my phone
  • unplugging and replugging the usb cable
  • restarting my computer (which also updated)
  • uninstalling the device driver (I did not get the checkbox option to delete driver but I did get this warning letting me know that I was uninstalling the device from my system and I continued with the uninstall)

enter image description here

  • Which OS are you running? – xavier_fakerat Jun 19 '18 at 16:02
  • @xavier_fakerat Windows 8.1 – TeaJay Jun 19 '18 at 20:45
  • I just updated my question and gave more information because now I am wondering if I am even supposed to see both the internal storage and the SD card if I formatted the SD card as internal storage. I thought that I had viewed both storage locations after I formatted the card, but now I'm not so sure. – TeaJay Jun 19 '18 at 21:23
  • @xavier_fakerat That is the opposite of my problem. I CAN see my SD card, but not my internal storage. I included a picture in my question and tried to clarify my question. – TeaJay Jun 22 '18 at 3:13
0

Looks like your MTP drivers are corrupted. One way to resolve is uninstalling the driver and then reinstall it.

Depending on your OS running on your PC, locate the device manager and uninstall the driver:

If on Windows PC;

  • Go to Device Manager, expand Portable Devices and right click on your device.
  • Select Uninstall (also tick the box besides Delete the driver software for this device) and click OK.

enter image description here

  • Unplug your device and restart your computer.
  • After the computer restarted, re-connect your device via usb and allow the MTP driver to be installed (it may take a while, so be patient)
  • When done check if the internal storage is now visible.
  • There is no Portable Device folders. I included a picture of my device manager in my question for you to see. – TeaJay Jun 19 '18 at 20:44
  • It should only show when your device is connected. Did it not? – singhnsk Jun 20 '18 at 9:47
  • I guess I wasn't connected. I connected and I was able to see my device as in your picture but there was no option to check delete driver software. I clicked uninstall anyway and got a window that said: "You are about to uninstall this device from your system." I clicked ok. And continued with your steps as directed. When I reconnected my device no MTP driver was installed. AMD catalyst control center opened though. I never saw that before. Was I supposed to do something? – TeaJay Jun 22 '18 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.