4

I'm having a problem with Google Translate and downloading offline packages for any language. I tap the download button next to the language, it says "Starting download" and the indicator is spinning, but nothing happens and the language pack is not downloaded. The app has the permission to use the storage.

My setup: the latest version of Google Translate (v5.20.0.RC10.199570264), on an Xperia L1 with Android 7. I should stress that with previous versions this used to work.

What I have tried:

1) Clearing cache and data of both the app and Google play (also the services).

2) Unistalling and reinstalling.

3) Rebooting.

4) Unistalling, rebooting and then reinstalling.

5) Moving the app to SD. Also the opposite.

6) Checking the permissions (everything is allowed).

7) All combinations of all of the above.

I'm about to try a factory reset, but before going nuclear I'd like to try some alternative.

Any hints/ideas are welcome!

4
+100

The issue was solved by clearing the data of download manager as confirmed by OP .

Go to Settings → Applications → Download manager → Clear data.

The download should proceed as normal.

  • This fixed my issues not only with the Google Translate app (which at least have some reasonable error code that brought me here), but also with the download functionality of the NPR One app which failed to download just some specific podcasts (which then appeared as incomplete in the downloads app). Thanks! – bers Apr 5 at 1:24
3

Solved turning off VPN... Never thought about this been an issue here.

Thanks for suggestions!

  • My problem was solved by turning off my Adguard VPN. – Arif B Jul 21 at 17:48
0
  1. Uninstall Google Translation (with the memory card on your mobile).

  2. Turn off the mobile.

  3. Remove the memory card.

  4. Turn on the mobile.

  5. Install the Google Translation from PlayStore and give full permisions to application.

  6. Install ALL the languages ​​you want to use offline.

  7. Turn off the mobile phone.

  8. Insert the memory card.

  9. Turn on the mobile.

  10. Copy the entire folder from the internal memory Android\data\ com.google.android.apps.translate to the exact same location on the memory card (if prompted, replace the same files that the memory card holds in the same slot).

  11. Restart the mobile.

  12. Now everything in Google translation works well.

0

I had this problem too. I changed wifi to cellular data . It solved!! Google couldn't downlad via wifi

0

Google translate offline the audio doesn'twork when you're trying to imput using audio ....the microphones is blanked out

and also the output there no audio ...... input is English and the output is Vietnamese I downloaded the file no problem

You can try to import in and afterwards you can get audio on the input but not on the output

Not the answer you're looking for? Browse other questions tagged or ask your own question.