0

I'm using Samsung Galaxy Trend 3 SM-G3502U, having android of version 4.2.2

Since this is a Chinese device, so it was normal to be shipped without GApps. So, I tried to to install the latest version among the versions which are compatible with Android 4.2.2 of the following apps from APKMirror:

  • Google Play Services
  • Google Play Services Framework
  • Google Calendar Sync
  • Google Contacts Sync
  • Google Account Manager

Still, no luck, since when I tried logging into Snapchat, a pop-up "popped" out, saying that google play services is not supported by my device.

Also, when I installed and opened the latest version of Play Store among the compatible versions for Android 4.4.2 from APKMirror, it showed "Error retrieving information from server RH-01" which meant that I didn't have the compatible GApps installed.

Now, are there anymore ways to try out for me so that my phone supports Google Services Framework, or I am left out with installing a custom ROM?

Any help will be appreciated.

Thanks in advance!!!

And wait, there is one more information I can give you if you find it useful.

Having all the apps listed above installed, I installed the "Device ID" app by Evozi. It couldn't show me the GSF. The space for that was left out empty instead.

0

The apks will not work without system libraries, and other frameworks that cannot be installed without root (or flushing from a recovery).

protected by Community Nov 3 '18 at 15:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.