0

A few weeks ago, my friend's Honor 7 display cracked. So I ordered a new display+frame from "Ali" as I already have done a few times before. After transferring all the hardware to the new frame and connecting everything as it was before, two issues arose:

  1. The battery seems dead. When plugged into a charger, the battery does not charge. But I found a useful thread which might work, so this is not the main issue.

The more pressing issue is:

  1. The phone enters a boot loop when powered up (it does not matter if I power it up with or without a battery). SD card and SIM card are not in the phone when powering up. The boot loop consists of a short vibration and then showing the first screen "Honor - powered by android", then going dark and starting over. It is to be noted that no rooting or flashing was done to this phone.

I already tried the old display again but now the same issue arises there too. It can only enter "Fastboot mode" not "Huawei eRecovery". When trying to enter "Huawei eRecovery", it just vibrates really short and then does nothing.

Since the phone is still locked and I can't power it up, my hands are kinda tied up. Any advice would be great. Even if it is just telling me that nothing can be done here.

1 Answer 1

0

You should take the phone to a repair shop and explain the situation to them. Most likely a physical component is damaged or not connected, and the bootloop is caused when Android first tries to initialize or use that component. If recovery has the same problem, but fastboot mode doesn't, that narrows the problem down to a component that's initialized by the recovery image, but isn't by the bootloader. It could be as simple as that some RAM or storage, but not all of it, is damaged. This damage could be permanent or could just be a faulty connection. Possibly it was caused by the same physical stress that broke the display in the first place.

1
  • The phone worked fine after the display broke so I guess I damaged a component when installing it into a new frame. Thank you for you answer!
    – ritocesura
    Commented Jun 20, 2018 at 15:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .