0

was experimenting( more specifically, trying to flash ROMs) with my Samsung Galaxy J1 Ace(rooted). It was all going well till I tried flashing the TWRP recovery mode. I followed all the steps mentioned on various xda forums but a red exclamation mark appears at the top left of the screen when I try to turn it on, along with the Samsung logo and it the phone just hangs. When I go to the download mode, it shows MDM Download : 0. I tried flashing, using ODIN, other versions of the TWRP for my phone model but the same error persists.

Is my phone soft-bricked?

How do I fix it?

I am trying to restore the original stock Samsung firmware now.

Many thanks.

  • Thanks a lot! Upvoted your answer and left a note there: while Odin is only available for Windows, there are two other similar applications which work with other OSes as well and could be used in the same way (just in case someone in the same situation has no Windows but e.g. a Linux machine running). // Will cleanup comments now as they got obsolete. Thanks again for sharing, and enjoy your further stay with us! – Izzy Jun 27 '18 at 10:28
1

Alright everyone, I have managed to solve the issue. If you find yourself in this same error, visit this site to know properly how to fix your SAMSUNG device.

In short, you need a PC running a Windows OS, a software called Odin(v3.07)[used by SAMSUNG internally, so its legit] and the original stock firmware. Download the proper combo( country-region and phone model).

Hold the Power, Home AND volume down buttons simultaneously for around 5 seconds(until the Download mode comes up).

Then connect it to your PC using a usb cable and run Odin. Now click on the PDA and navigate to the extracted stock Samsung firmware file (MD5 type). Select it and wait for a while, the Odin will take some time (around a minute) to check and process the MD5 file.

Then click 'Start', let the flashing finish(takes around 10-15 minutes) and voila!

  • Thanks and thumbs-up for sharing your solution! Just to point out, there are alternatives to Odin, mentioned in our odin tag-wiki. So especially when using a non-Windows machine and having no Windows machine at hand, the same approach should work with JOdin3 or Heimdall (link again to the corresponding tag-wiki). – Izzy Jun 27 '18 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.