I'm trying my best to determine a method of recovering some deleted data on my Samsung S5.

I've used tools such as Recuva in the past to recover files on flash drives and devices of that nature. However, when plugging my Android device into the computer, it seems I can only select options such as Charging, MTP, etc - none of which actually assign a drive letter to the device and therefore make it impossible to run these recovery tools. I see USB Mass Storage used to be an option, but appears to have been removed from the Android OS at some point.

The device was accidentally wiped and reset. It is rooted with SuperSU installed, and I've been taking special care to not use the device so I can avoid overwriting data. I've tried multiple Android-specific recovery tools, though they either don't recognize that the device is rooted or never prompt for root permissions, and therefore haven't been of any use.

My question is this:

  1. Is it somehow possible to mount the device as a drive so that I can run recovery tools against it as I would a flash drive.
  2. Otherwise, is there some way to mirror the entire disk so I can run recovery tools against it separate from the physical device?

Thank you!

Update

I've figured out how to make an image of the disk, I believe (it's a 14.7 GB image, and the internal disk is only 16GB, so I'm thinking I imaged the right partition), and that seems to be some progress. I did the following:

adb pull /dev/block/mmcblk0 mmcblo0.img

Now that I have this image, I've tried scanning it with a tool called Autopsy, but I don't see many deleted files listed. How should I proceed given an image of the disk?

  • Welcome to Android Enthusiasts! Have you already consulted our data-recovery tag-wiki? That question has been raised before :) – Izzy Jun 25 at 21:49
  • 1
    I was not aware of that, but I will certain look it over. Thank you! – Tyler Jun 26 at 5:01
  • It's not that obvious – especially not to newcomers. Many of our tags have such wikis, always worth a look before asking :) After you've checked there, please make sure to come back and either answer your own question when you've solved your issue, or edit it with additional details on what you've tried and where you're stuck. Afraid however your solution will require root access (or at least an unlocked device to use a custom recovery), as only root has low-level access to make a bit-wise copy of the file system. – Izzy Jun 26 at 5:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.