I'm having the problem mentioned in the title on my Samsung Galaxy S. I updated the app Dock Simulator and for some reason it got stuck while installing. Now it shows the scrolling green bar in the downloads section of the market but the program itself works fine. How can I get rid of the constant "Installing..." status?

Oh yeah, reboot and uninstall didn't fix anything.


9 Answers 9


I just had this problem, and somehow I got this solved.

What I did:

  • Entered Settings -> Applications -> Manage Applications.
  • Selected the Market app, and "uninstall updates".

After that, I entered the Market app again, and I was able to reinstall the app who got stucked.

PS: I'm not sure if this was just a coincidence, or this procedure works always, but it worked for me. PS2: My Android version is actually in portuguese language, so I'm not sure the option names I referred to above are correct in english.

  • No such option in Android 8.
    – david72
    Aug 16, 2019 at 21:34

Try to do the following:

  • Close the Play store.
  • Go to settings
  • Select the apps option
  • Find the Google Play store, and select it
  • Tap "Storage"
  • Select "clear data"

Then, try to download your app again.

  • Did not work for me. It did work when I cleared Google Play Services data but just for one time. When I tried again it was again stuck.
    – david72
    Aug 16, 2019 at 21:26

In the " downloads" screen of the market, long click on the app that's stuck installing and you'll get the option to Delete or Cancel (I can't remember which option you'll see but it'll be obvious).

  • I tried that too, didn't work. Also tried clearing caches from Market and most of the others that could possibly have any relevance to the matter, but finally got frustrated and wiped the phone. But thanks for the suggestion :) Oct 7, 2010 at 8:03
  • 1
    +1: it works for me. thanks! that's been annoying me for a couple of weeks! (Moto Droid) Oct 7, 2010 at 14:14
  • Stop all the updates which were waiting for Wi-Fi to update. And start fresh install worked . Thanks Nov 7, 2015 at 5:41

Worked for me: Setting > Apps > All > Google play services > Uninstall update and clear cache


I keep getting this, and it seems tied to my "Application storage is low" message.

I uninstalled several large, un-used apps, rebooted*, and the downloads downloaded.

*Maybe I didn't reboot. Check the download after uninstall and see if it's continuing....

Since my file-browser says I'm using less than 40% of available phone storage, this is a little irritating.


What helped me was to uninstall the updates for Play Store and Google Play Services, and delete the data for these apps. I got lots and lots of error messages immediately after, rebooted, got lots more error messages, but eventually the (old) Play Store opened and downloaded an update for "Google", and voila, everything was back to normal.

Uninstalling the updates to Google Play Services must have been the crucial step, because I fiddled with Play Store and various other apps for quite a while before trying this one.


My is working when i close the app when the downloading app is at 100% or it didnt start at all i open the app again and its started installing and my app is installed. It isnt a very effective way but its something. :)


install latest version of play store and play services and then reboot your phone . Play store version 5.3.6 Play services version 7.9.90

  1. Clear cache
  2. Clear data
  3. Uninstall updates of google play store Then the problem is solved.
  • 1) If you're suggesting "Clearing data" then here is no point in explicitly mentioning "Clear cache" since clearing data would take care of it. 2) Your answer adds nothing valuable since all the info is covered in rest of the answers. Please refrain from adding redundant information since it doesn't help. Thanks!
    – Firelord
    Feb 21, 2016 at 1:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .