1

Summary

  • Nexus 9
  • Never rooted the device and boot loader is locked
  • Stuck in a boot loop since an android update
  • Factory Reset doesn't work
  • Recovery mode doesn't work
  • Can't flash anything
  • Can't unlock boot loader due to OEM setting
  • OEM setting can't be turned on due to boot loop

Context

I bought nexus 9 and I have never rooted this tablet or have done anything fishy to it.

Within few months I received a new android update and I got stuck in a boot loop with a message "Your device is corrupt..." and I lost access to my precious non backed up pictures. However, I have abandoned the pics and decided to try factory reset. I get stuck with a green android icon when I try to factory reset for about half an hour then it reboots, but it still gets stuck in boot loop.

So then I try to start the recovery mode but then I get stuck with a dead green android icon with red warning sign.

So what do I do next? I try to flash a custom recovery program, TWRP.img using fastboot but I can't because the bootloader device status is locked.

So I try to flush all preinstalled img to stock, so I try unlocking boot loader using fastboot oem unlock but I can't because I didn't turn on the OEM permission on before being bricked. If only there were way to turn on OEM from adb but I see a lot of people saying its not possible.

How can I fix my tablet?

1

You should still be able to sideload an official OTA update from the stock recovery. You can get the official OTA images here: https://developers.google.com/android/ota

  1. Download the latest OTA image for the Nexus 9 from that page

  2. Reboot into recovery mode

  3. Press the volume up and power keys at the same time to activate the hidden menu

  4. With the volume keys, highlight “apply update from ADB” and press the power button to choose it

  5. From your computer, execute adb sideload otaFilename.zip

  • Amazing it worked, well first try I got status 7 error "Can't install this package over newer build" but I just got a newer OTA and it worked. Well, I also uploaded a wrong OTA and got a status 7 which saved my bum from hard brick. – Wanting to be anAndroidDevelor Jul 1 '18 at 21:15
  • 1
    However, I don't really know what I just did could you explain it a bit just for interest? – Wanting to be anAndroidDevelor Jul 1 '18 at 21:15
  • @WantingtobeanAndroidDevelor sure, so basically what you did was the manual method of doing the exact same thing that the built-in "System Update" does. – Android Dev Jul 2 '18 at 14:59
  • Very cool, thank you does this mean that I didn't need to run the factory reset and would have still fixed it? – Wanting to be anAndroidDevelor Jul 2 '18 at 16:40
  • @WantingtobeanAndroidDevelor that depends if your /data partition was corrupted (factory reset needed), or if only the /system partition was corrupted (factory reset not needed). – Android Dev Jul 2 '18 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.