I always used to transfer files between my laptop and Nexus 5X phone. Upon connecting the USB cable, there used to be a notification thingy on my phone showing USB options, which was default on 'Charging' and then when changing that to File Transfer, I could transfer files.

I recently had to reset my phone and now that I have a new, freshly installed Oreo 8.1.0 environment, this USB notification does not appear anymore. And the device does not show up on my laptop at all.

While searching for a solution I came across these suggestions which I already tried:

  • Enabling developer mode on Android (clicking 7x on Build number in About).
  • In developer options, enable and disable USB debugging.
  • Clearing the cache and data storage for the 'External storage' and 'Media storage' apps, and rebooting my phone, and wait for a while.
  • In developer options, there is something called "Select USB configuration" which is on "MTP (Media Transfer Protocol)". Changed that to "Charging" or "PTP (Picture Transfer Protocol)" and back.

None of these helped, unfortunately. Any hints?

Note that the cable is fine. It works OK on other phones, and upon connecting my phone to my laptop, it does show the charging indicator in the battery icon. It's just the USB notification and file transfer related options that are no longer there.

  • I know you say "the cable is fine", but I'll just emphasize that a USB cable that is fine for charging may not be fine for file transfer. That detail cost me almost an hour of trying to find an Android solution to a hardware problem.
    – RenniePet
    Commented Mar 24, 2019 at 22:04

7 Answers 7


Go into Developer options, scroll down to "Select USB Configuration" and select MTP ( Media Transfer Protocol ) even if it's already selected.

This solved the problem for me.

  • 2
    Ridiculous solution, but it worked for me
    – geotheory
    Commented Jun 8, 2019 at 10:36
  • This Developer options is not in my Android 8.1's setting (as per question). Can you specify.
    – Hugolpz
    Commented Mar 11, 2022 at 16:23
  • @Hugolpz You have to go into Settings, System and then do some kind of absurd cheat code you can probably find on the internet, and forever afterwards it will be in Settings, System. That's part of why this solution is "ridiculous", since you have to go into options that are literally intentionally hidden.
    – Mr. Nichan
    Commented Apr 20, 2023 at 20:55
  • This didn't work for me, because every time I left Developer Options the USB configuration immediately reset to charging, as if I hadn't saved my changes, except that there is no button for saving changes.
    – Mr. Nichan
    Commented Apr 20, 2023 at 21:00
  • Rebooting didn't help either. Right now I guess that clicking "always" after selecting the "charging" option on the popup causes some process to automatically change the USB configuration to charging no matter what you try to change it to manually.
    – Mr. Nichan
    Commented Apr 20, 2023 at 21:07
  • Go to developer options
  • Make sure using "USB Debugging" is disabled
  • Set "Always Prompt when connecting to USB" to ON
  • Make sure your phone is unlocked when you connect to the PC/Laptop
  • Select "File Transfer" in the options.

I learned this from Huawei Support who were very easy to deal with from here in the UK.

  • 2
    Confused about the last step. Select "File Transfer" where, or in what options, exactly?
    – RocketNuts
    Commented Sep 7, 2018 at 18:19
  • Did they - by any chance - mention a way to make the setting permanent? Every time I set it to file transfer, it keeps getting reset to charge only when I unplug and re-plug the device Commented Nov 25, 2020 at 14:58

For Lineage OS you need to go to Developer options

  • disable "USB Debugging"
  • scroll down and between "Tethering hardware acceleration" and "Show bluetooth devices without name" you could find
  • "Select USB Configuration" and press it.

That's it. but my phone showed me the Internal storage only after I picked up PTP first, tried to extract images (unsuccessfully) and when I returned back to MTP everything was OK .


The old menu which used to be available from the charge notification is now well buried (Moto G5) at:

System → Settings → Connected devices → USB → Transfer files.


Go to developer options> enable usb debugging > click Revoke USB debugging authorisations Press and hold down power+volume up until phone vibrate and restart. After that the problem should be solved. But remember, this is not a permanent solution.


Under settings did you go to Connected Devices and you will see USB listed there.

Also for the notification not showing anymore, under settings, go to Apps and notifications > Notifications > Notifications again and at the top right click the 3 dots menu and select "Reset App Preference"

This way any notifications won't be blocked from showing and when you attach the USB it should come up again


For me it was an hardware problem. The usb cable I was using was able to charge the phone but for some unknown reason it didn't work for the transfer.

I changed cable and suddendly it worked flawless..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .