2

I have work profile enabled on my Android Oreo 8.1 device and I disabled (turned off) the work profile from the notification drawer menu. Now, when I tap the button to enable (turn on) work profile again, it asks for my pin and then settings app crashes (Settings has stopped", without enabling the work profile. This keeps happening.

Any idea of this is a bug with Android or something wrong with Xiaomi's build? Are there any workarounds to enable (turn on) work profile again? I tried from the settings menu also, but results in the same crash.

Specs:

Xiaomi Mi A1 with Android version 8.1.0 and security patch 5 June 2018

Kernel version 3.18.71-perf-g4a631fd (gcc version 4.9.x 20150123 (prerelease) (GCC) ) builer@mi-server #1 Wed Jun 20 14:23:03 WIB 2018

Build number OPM1.171019.019.v9.6.3.0.0DHMIFE

Screenshot:

screenshot

4
  • I have same device except that I am on May update. Tried this - same problem . It looks to be a Xiaomi bug
    – beeshyams
    Jul 5, 2018 at 15:25
  • Yes! Was searching on the Mi community forums and found a post from 2018-01-27: c.mi.com/thread-733447-1-1.html
    – Shahidh
    Jul 5, 2018 at 15:56
  • This is still happening on Android 9.0 :(
    – Shahidh
    Jan 24, 2019 at 4:44
  • FWIW, this also happens on my Nexus 5, LineageOS 14.1 (Android 7.1 Nougat), so I don't think the issue is exclusive to Xiaomi devices (though, without knowing the real cause, it's hard to confirm).
    – Andrew T.
    Mar 22, 2020 at 12:18

1 Answer 1

1

Removing work profiles from settings > accounts and adding again worked for me. Still better than doing factory reset.

1
  • Then you'll have to re-install all the apps etc. Pain! Need a solution other than factory reset or removing work profile.
    – Shahidh
    Oct 10, 2018 at 12:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .