0

So, for whatever reasons, I like disabling Google services which I do not use. Since Android does not allow me to fully uninstall Google apps, I try to reply on the "Disable".

However, what I am noticing is that the Google app still shows a Force Stop button (see screenshot below). This suggests that the app is still running something. This does not happen with other (non-Google) system apps which I have disabled.

So, why do the stock Google App(s) continue to run? What do they do in the background? What is the whol point of disabling if they can still run? And is there a way to fully disable the app and stop it from running?

I am using an unrooted OnePlus 5. I have tried on a OnePlus 3T and a Nokia 7 plus with the same result. I do not intend to root my device. Disabled Google app

  • 1
    Without root not possible – beeshyams Jul 7 '18 at 9:55
  • There is no way to fully disable it without root, but there is a new way to remove system apps without root. I didn't believe it when I came across this on Reddit, so I tested it myself, I can confirm that this works. I tested this on a unrooted One Plus 3T running stock firmware. Link xda-developers.com/… – Martin12 Jul 7 '18 at 10:30
  • I checked that before posting. But it does not answer "Why and how". That's what I'm more interested in. Why non-google apps fully stop but not the Google ones? – singhnsk Jul 7 '18 at 14:31

Browse other questions tagged or ask your own question.