1

I'm using the app 'Automate', in order for it to work I have to turn it on in Settings/Accessibility: accessibility But after a short time I doesn't work anymore and it's back on 'off' again. I think it may have something to do with my battery saving mode because I've seen it in a different question but no idea how to fix it because my gui doesn't have the same properties as suggested in an answer I've seen somewhere else. Battery saving I'm using an Honor 9 phone from Huawei, my software versions: software So my question is: How can I prevent my phone from changing the app's accessibility setting without giving up on the battery saving feature (if that is the reason for it)?

  • Ensure Automate is enabled as a "Protected App". – ballzak Jul 9 '18 at 18:43
  • @ballzak Where do I enable that? – Cold_Class Jul 9 '18 at 18:52
  • Dunno, it's a non-standard Huawei feature. – ballzak Jul 10 '18 at 2:31
0

This probably is the battery saving mode (Android 7) as you suggest.

On my Samsung you can mark Automate (or any other app) as an app not to be checked for battery drain.

  • From Settings, select Device maintenance.
  • Select Battery at the bottom left of the screen.
  • At the bottom of the next screen is a list of apps that are currently considered by Android as using power. Automate is probably on that list.
  • Below the list is a button "Unmonitored Apps", select this.
  • Select Add apps and add Automate to those apps that are no longer checked and put to sleep by the OS.

The exact method may be slightly different on your phone but the principle should be the same.

  • The first point 'Device Maintenance' is already not there on my phone :( – Cold_Class Aug 16 '18 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.