3

TWRP and TWRP Treble give me error of "Zip file is corrupt" when I install zip roms or files. I wiped all the things that needs. (/Dalvik Cache, /System, /Data, /Cache) but nothing changed.

I redownloaded 2 or 3 times and checked the MD5 and it was all fine.

twrp getting error

  • So what is unclear here? File is corrupted so download new gapps from here and be happy. Be aware you should pick only appropriate version for your system. – Suncatcher Jul 9 '18 at 6:14
  • 1
    I downloaded from there although, I downloaded many other roms and checked it by MD5 and it was all fine, but twrp gives me that error. @Suncatcher – Mahdir Jul 10 '18 at 8:59
  • Agree with breversa answer. If it always says "corrupt" then reinstall TWRP and check that your internal storage is not corrupted. Try to change the way you copy gapps to storage (if you using MTP try adb and vice versa). – Suncatcher Jul 13 '18 at 13:22
0

If your zip file is corrupt then no wiping will change anything.

You'll need to redownload the file, and check the checksum to see if it's been corrupted during transfer. If yes, you may want to redownload it again, using a different mirror.

Alose, be sure to get the right OpenGApps package for your Android version and device CPU architecture.

EDIT : My bad, I didn't read your whole comment. Have you tried reinstalling TWRP (again, checking the checksum) ? If EVERY zip file is seen as corrputed by TWRP, it might be your storage that's damaged. Using the "Repair" function may help.

| improve this answer | |
  • Tnx. Yes, i checked the md5 of the files, and reinstalled the twrp. both old and new twrp can't install. i tried many zips. roms and pico gapps. not works. My storage which zip files are there is an external storage, a sdcard, because I can't put files in my phone storage and install it with twrp after formatting and wiping. – Mahdir Jul 10 '18 at 8:58
  • Where is "repair" function dude? – Mahdir Jul 10 '18 at 9:01
  • how can I put the zip file in internal storage because that would be removed after wiping and formatting? and there won't be an OS to put it again. and I can't copy files in mount function. (I can just read it) – Mahdir Jul 10 '18 at 9:03
  • The "repair" function is in Wipe/Advanced wipe. – breversa Jul 10 '18 at 9:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.