I get "Internet may not be available" on my new Samsung J5 Prime around every 5 minutes.
This did not happen with other Android devices on the same Wi-Fi router.
What can be the problem?

Model SM-G570M
Android 7.0

enter image description here

  • Have you tried setting static IP address? Also check the DNS settings Jul 22, 2018 at 16:07
  • @xavier_fakerat How should I check it and what should I check for?
    – Petruza
    Aug 1, 2018 at 5:15

4 Answers 4


As strange as it seems, I now have come to an understanding that this issue may be related to an IP address conflict between the router and the connecting device or at least a faulty DHCP implementation (as discussed in some Samsung forums but for slightly different models).

It could perhaps a bug related the way the router handles 2.4GHz <=> 5GHz switching, causing an uncomplete handover (5GHz SSID to 2.4GHz or vice versa) (but users complain its worse when dealing with 5GHz only)

A probable workaround is setting static IP address for the wi-fi:

  • Go to your wifi connections, long tap on the connected wifi, until it gives you option to manage network setting,

  • Then choose advanced option, and put your IP type on static, then use a new ip address (for example, if it's 192.168.1.x change it to 192.168.1.y where y can be a value 2-100 for simplicity )

  • Make sure that ip is empty in your router and your gateway is your router IP address, first DNS your router IP address, second one Google DNS ( or and save it, turn your wi-fi off and on.

You may preferentially set the wi-fi SSID to use the 2.4GHz range.


  1. S9 wifi internet may not be available
  2. Galaxy S8 Wifi Issues

This is the stupidest darn thing ever but SOME ROUTERS like Freedom home internet (aka Shaw) & their wifi hotspots from phones using the same ISP(Freedom mobile) have a security setting somewhere that leaves your device as "The internet may not be available" if your device is set to the Wrong. Dang. Timezone.

I'm serious. We spent 3 hours trying to fix it, and it was Google Chrome's "your connection might be unsafe" page that suggested updating your system time.

Flicked on "automatically detect time", the clock switched from 21:05 to 20:05 and the internet just magically turned back on. Tah-dah!

  • This is actually expected for HTTPS connection due to SSL/TLS handshake needs correct time.
    – Andrew T.
    Mar 8, 2021 at 3:23

Just bought a new Samsung J9 phone which had the same problem. I unsuccessfully tried various fixes but finally (should have done this first!) looked at the IP settings. The Ip was set to a static value of However, my home network has IPs 10.1.1.xxx. When I changed the IP setting from Static to DCHP and switched the phone on and off, the problem was solved.


I found the following step worked for me.

  • Make sure you are connected to the wif-fi network on your Android mobile phone
  • Modern routers have a WPS button, normally next to the LAN connections. Depress that button. You should see the wireless symbol on the wireless router blinking.
  • Now on the Android mobile phone go to Settings -> Connections -> WiFi, press on the three vertical dots on the top right of the screen
  • Choose "Advanced"
  • Click on "View More"
  • Click on "WPS push button
  • The WPS setup screen will appear and it should connect with your wi-fi router Once connected, restart you mobile and the now you should be able to connect to the internet via wi-fi

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .