1

I get "Internet may not be available" on my new Samsung J5 Prime around every 5 minutes.
This did not happen with other Android devices on the same Wi-Fi router.
What can be the problem?

Model SM-G570M
Android 7.0

enter image description here

  • Have you tried setting static IP address? Also check the DNS settings – xavier_fakerat Jul 22 '18 at 16:07
  • @xavier_fakerat How should I check it and what should I check for? – Petruza Aug 1 '18 at 5:15
1

As strange as it seems, I now have come to an understanding that this issue may be related to an IP address conflict between the router and the connecting device or at least a faulty DHCP implementation (as discussed in some Samsung forums but for slightly different models).

It could perhaps a bug related the way the router handles 2.4GHz <=> 5GHz switching, causing an uncomplete handover (5GHz SSID to 2.4GHz or vice versa) (but users complain its worse when dealing with 5GHz only)


A probable workaround is setting static IP address for the wi-fi:

  • Go to your wifi connections, long tap on the connected wifi, until it gives you option to manage network setting,

  • Then choose advanced option, and put your IP type on static, then use a new ip address (for example, if it's 192.168.1.x change it to 192.168.1.y where y can be a value 2-100 for simplicity )

  • Make sure that ip is empty in your router and your gateway is your router IP address, first DNS your router IP address, second one Google DNS (8.8.8.8 or 8.8.4.4) and save it, turn your wi-fi off and on.

You may preferentially set the wi-fi SSID to use the 2.4GHz range.


Acknowledgements

  1. S9 wifi internet may not be available
  2. Galaxy S8 Wifi Issues
| improve this answer | |
0

Just bought a new Samsung J9 phone which had the same problem. I unsuccessfully tried various fixes but finally (should have done this first!) looked at the IP settings. The Ip was set to a static value of 192.168.0.100. However, my home network has IPs 10.1.1.xxx. When I changed the IP setting from Static to DCHP and switched the phone on and off, the problem was solved.

| improve this answer | |
0

I found the following step worked for me.

  • Make sure you are connected to the wif-fi network on your Android mobile phone
  • Modern routers have a WPS button, normally next to the LAN connections. Depress that button. You should see the wireless symbol on the wireless router blinking.
  • Now on the Android mobile phone go to Settings -> Connections -> WiFi, press on the three vertical dots on the top right of the screen
  • Choose "Advanced"
  • Click on "View More"
  • Click on "WPS push button
  • The WPS setup screen will appear and it should connect with your wi-fi router Once connected, restart you mobile and the now you should be able to connect to the internet via wi-fi
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.