1

My phone (Galaxy Note 4) running Android 6.0.1 can't do anything internet related unless the process is running in the foreground. I've been dealing with it for so long, but now I'm stuck in the hospital after serious surgery for the second time and I really would like it to work this time... :(

This is the error script, from leaving Facebook in the background to post a video. My phone isn't rooted or anything so it's the best I know how to offer:

9zf caught Execution Exception, com.facebook.tigon.tigon utils.TigonErrorException: TigonError(2): TigonLigerErrorDomain(2) AsyncSocketException: con-nect failed, type = Socket not open, errno = 111 (Connection refused) java.lang.RuntimeException: 9zF caught Execution Exception, com.facebook.tigon.tigon utils.TigonErrorException: TigonError(2): TigonLigerErrorDomain(2) AsyncSocketException: con-nect failed, type = Socket not open, errno = 111 (Connection refused) at X.9zF.D(1746707) at X.9zF.iyA(1746720) at X.24s.run(:497658) at java.util.concurrent.Executors $RunnableAdaptercall(Executo rs java: 423 *

  • {facebook cut the rest off, but the next line, I think, is this}

I'm tech savvy but not this tech savy. My phone will do nothing internet related in the background, nothing. Whatever it is, as soon as it's not running in the foreground, it zonks out. Screen turning off drops my calls (I use an internet number), messages aren't delivered unless I open the app, etc etc Messenger (for Facebook) in particular acts really funny about connecting; after it zonks out and I reopen it, I have to disconnect and reconnect to the WiFi or it'll just sit there telling me I have no Internet. Other apps basically do that too, though. Everything was the same even when I used to have phone service and mobile data, switching between them, I believe, would fix it too.

Not sure how relevant this is, but my phone totally rejected being rejected to "sign in" (I quote because it claimed I needed to sign in in my settings, but just wanted to redirect me to the hospital page before it would work) to the public WiFi network here, and it always has silly little troubles like that. It kept saying Google refused the connection or giving me the generic dinosaur error. Everyone else seemed to do fine with it, finally after a million times of trying things, going to Google.com manually did work.

I disabled a lot of system components once upon a time because there are a lot that i just do not need ever running on my phone and wasting my battery. My best theory is I selected one (maybe even more) accidentally and caused this but I have no idea which one. My fear is some kind of virus/hacker/personal data stealing something or other hiding in my phone. I used to install modded versions of applications from the internet because I'm a fool. This is a pretty old phone, my non-stone-age one is broken.

I also bought it used and clearly very refurbished (not even well) from a sketchy auction on eBay, so that's another reason I'm concerned. It's probably nothing, haha. My device status claims to be official, I couldn't find anything particularly sketchy in my phone's information.

I don't remember when this started happening but I feel like it wasn't after disabling anything or I would have noticed? I'm probably wrong, though lol

Thanks in advance! ♡Quinn

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.