Some time ago I installed a custom firmware (YAR28) on my Archos 7HT. This worked fine for a while, until some day when I switched it on it showed the initial startup screen, and after that all my installed apps were gone. So I re-installed the stock firmware from Archos. But then I found out I could no longer access the sd-card. It was not mounted when I inserted it. But when I connected the device to my PC using USB it did show up as drive F: and G:. I could access F:, which was obviously my sd-card, but G: (which should be the internal flash) could not be accessed, and Windows even asked if this should be formatted.
When I open the Files on my tablet, and select 'SD Card' it gives the 'SD card is unmounted' error. And when I select 'Internal Memory' it is completely empty. So it looks like the file system is still working, but the internal flash part somehow is no longer accessible.
I have a feeling that some low level setting has changed and that I could somehow solve it if I could get access to the underlying Linux system, but I do not have a clue how to proceed.

1 Answer 1


Indeed the internal filesystem somehow got damaged. To fix this you need access to the filesystem itself, which can be done using ADB. (Android Debugging Bridge) Instructions for connecting to the Archos Tablets using ADB can be found here:


Although the description is complete this still sometimes can be hard. You might have to restart your computer a few times, but eventually it is possible.

Open a command window in the directory containing the ADB.exe program (it is in the 'platform-tools' directory under the androis-sdk-windows folder)
If the connection is OK, it will start a server and after e few seconds show the '$' prompt. this means you are connected to the tablet and have direct access to the linux shell. If you type 'ls' you will see a list of folders that contain the operating system and all supporting files that make your tablet work.
Now navigate to the folder containing the Flash file system by typing:
cd ./dev/block/vold
If you now type 'ls' again you should see three or four folders that have numbered names. One of them is '31:8'. This is the folder that points to the internal flash. Now we can fix our problem by recreating the MS-DOS (FAT32) file system on this partition. Type the following:
mkdosfs -F 32 /dev/block/vold/31:8/
This will fix the FAT32 filesystem. Now leave the shell by typing 'exit', disconnect the USB and restart your tablet. On my system this made internal storage re-appear, and after that it also mounted the sd-card. Problem solved.

Many thanks to this post on SlateDroid that contained the answer.

  • Thanks a lot! This command we can write in Terminal Emulator, but we must have root in our device. mkdosfs is standard command in Android 4.0. In my Maxell C7 folder name is 31:9 (not 31:8). If you will be in /dev/block/vold write "ls" and all folders in this folder you can see. After this we can succesfull this operation.
    – user22821
    Commented Oct 24, 2012 at 16:19
  • For me it was newfs_msdos -F 32 /dev/block/vold/179:32 . I've also seen busybox mkfs.vfat /dev/block/mmcblk0p19 so it all depends on what device You have. Anyway thanks for help.
    – kcpr
    Commented Oct 13, 2014 at 14:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .