2

Hello, I am trying to setup Android Studio 3.1.3 in a windows 10 x64 pro VM. I have installed Android 6.0 in AVD for ARM EABI architecture on a Pixel.

However, when I try to launch the emulator I get

Emulator: audio: Failed to create voice `goldfish_audio_in'

Emulator: qemu-system-armel.exe: warning: opening audio input failed

and the emulator is just a black screen that does not respond to anything.

I have everything enabled in Virtual Box regarding hardware acceleration.

I checked these posts:

Is it possible to run Android Device Emulator (via Android Studio 2) on VMWare?

“emulator: warning: opening audio input failed” displayed in the console while AVD is launching

Android Emulator: Audio Input Failed

but doesnt seem to get me anywhere...

I have also tried to disable sound in config.ini or disable the microphone in windows 10 VM but didnt change anything.

Am I missing something here?

Is it impossible to run android emulator for ARM architecture on a VM?

2

Uninstall Intel x86 Emulator Accelerator from windows control panel. Then install it again in android studio.

Tools => Android => SDK manager => SDK tools => Intel x86 Emulator Accelerator (HAXM installer).

Then make sure that you plug a microphone or a line - in cable to the input socket of your pc.

This is how I got my own issue disappeared.

0

Try reinstalling Intel x86 emulator accelerator, you can find it on your control panel That should work,in case it doesn't work try reinstalling the entire android studio because sometimes it fails to download some plugins which causes this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.