Dear android enthusiasts!

I'm not sure this is the right place to ask but I'm being really desperate and out of ideas what to try. I have a Galaxy S6 Edge (SM-6925F) running Android 7.0 (Kernel 3.10.61-13115714). The problem is: I cannot access the phone via USB anymore.

It used to work until a few months ago. It stopped working on one computer, some time later also on all others. When I connect it to a USB port, it charges just fine, but does not display any USB options that would allow me to select what it should do (the connected for charging notify doesn't even pop up). Here is what I tried:

  • Standard answer is to enable the developer options and then enable USB debugging. I did that, no change.
  • In the developer options I can set what the phone should do when connected to USB. Changed from MTP to "charge only" several times, also tried the other options like PTP, even setting it to audio source for fun. Tried changing options and disconnecting/reconnecting, restarting phone, restarting host PC, just nothing.
  • Tried the *#0808# thingy. Again, this allows me to select the USB options but no matter what I select, nothing changes.
  • Other standard answer is drivers. Well, there is not much I can remove in my device manager as the phone doesn't show up anywhere. I don't hear a "USB device connected" sound, it doesn't try to install anything. I did try to uninstall and reinstall the drivers from [*], again with no effect. I tried Win7x64 and Win10 hosts. Nothing.
  • Changing the cable. Tried three different ones.

I'm out of ideas what else I can try, except for the full factory reset of the phone. I was trying to avoid that due to the hassle with reconfiguring everything. Therefore I was wondering if there are any other options or if I have to go for that.

Thanks in advance!

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.