1

(Sorry for my english) My phone, Samsung galaxy S3 16 GB wasn't rooted and installed custom recovery. Someday, it appears on the screen that "internal storage is damaged". So I want to backup internal storage, attempted flashing twrp and rooting the phone through CF-autoroot, but it unable to mount /data in twrp.

To create a internal memory dump, I find this article.

https://dfir.science/2017/04/Imaging-Android-with-root-netcat-and-dd.html

I tried to this.

adb devices 
:: List of devices attached 
:: 4300********061 recovery

/data directory is empty.

adb shell 
su 
:: permission denied

I think phone isn't properly rooted. Installing a supersu.zip from twrp, it says "install failed".

adb forward tcp:8888 tcp:8888 
dd if=/dev/block/mmcblk0 | busybox nc -l -p 8888 
nc 127.0.0.1 8888 > android.dd

It created a dump file of 3.5 GB size on windows, although internal memory had 15 GB in use. And mounting the dump file from OSFMount is failed.

In this situation, is it possible to get a full memory dump of internal storage, specially /data partition?


Update.

Retry dumping of /data partition, and view this dump file from testdisk in linux. It worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.