7

When writing lists in Google Keep, sometimes infuriating Clippy-style auto suggestion popups appear, suggesting different things starting with the same word that another person might have wanted to write. These popup boxes are distracting and get in the way, usually overlapping the space I want to press to move to the next item in the list and obstruct seeing what I've written.

I want to turn this feature off. I've been through the settings and help, but there doesn't seem to be any option to turn it off. I've also sent feedback through the app asking for an option to turn it off to no avail.

Looking at the forums, I see people have been asking for a way to turn this off since 2016. There's a common old suggestion that it only turns on if something relating to "Shopping" is in the list title - but in 2018 I still get the popup plague even on lists with no title.

Is there any roundabout way to disable this which works?

1
  • 1
    I'm all for dumbing down or simplifying apps as much as possible, including minimal settings pages, BUT there should also be an advanced settings option which gives access to absolutely everything that could be tweaked. If they can spend weeks working on an option to autocomplete my shopping lists, they can spend a moment on an advanced setting to turn it on and off. It seems that even the biggest companies lack understanding of basic common sense software engineering principles, which would be self evident to any thoughtful child programming enthusiast. Commented Feb 17, 2023 at 8:55

3 Answers 3

1

Start each list item with a space. That way, you still get your keyboard's auto suggestions but you don't get the annoying Keep ones.

2

There are some workable workarounds buried in this forum thread.

The simple way (which makes writing lists take slightly longer):

  • Initially, create the list as a normal note with one line per item (not a checkbox list)
    • OR if it's already created as a checkbox list, press 'Hide checkboxes' under the three vertical dots in the top right. Unfortunately this causes Keep to forget which items were ticked.
  • Finish writing or editing the list
  • Press the '+' in the bottom left corner, then press 'Tick boxes' to turn it back into a check list

The more involved way (which in theory, you can do once then forget about)

  • Install a url filter like an adblocker and add the URL for Google's "show some popups of things I didn't type" service to the list of banned addresses. I've not tried this, so I can't guarantee it works - in particular, I don't know if it requires rooting the device or not (please comment if you have tried something like this). Two suggestions from that post:
    • The app uBlock, then going to "Settings -> My Filters" and adding https://taskassist-pa.clients6.google.com/v2/taskassist:suggest*
    • AdBlock, then going to "Customize > Manually edit your filters" and adding /v2/taskassist:suggest$domain=taskassist-pa.clients6.google.com

Don't forget to also go to "Help & feedback" in the app and tell Google that you want a normal option to turn off auto suggestions.

0

I deleted the keyword, made a new keyword, and the old keyword suggestion was gone. I think it only started doing it when I made the first word say "breakfast" in capital letters.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .