I am complete novice on adb. When it comes to Android I could be classified as "dumb user" - trying however to get one level up, hence playing with adb:

$ ./adb shell
error: device not found
$ ./adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached 

Looks like adb cannot see the connected device.

How to rectify the problem?

For your info:

  • the device is visible and I can copy files to/from it
  • I went through the steps suggested below and still no luck
  • I tried connecting the phone to different USB ports - my comp has 2 USB controllers - one USB 3.0 and one USB 2.0

Steps to enable USB debugging on my device with 7.0 Nougat Android:

  1. Go to "Configuration"
  2. Go to "About Telephone / Android 7.0"
  3. Click several times "Build Number" until message "You're now developer" appears
  4. Go back to "Configuration" - "{} Developer options" are now visible - go inside
  5. A number of fabulous options appear - switch-on "USB Debugging"

I am using Linux and I would prefer to stay away from Windows.

Still no luck - device not found

  • 1
    Check if the device is visible for adb with this command adb devices. Jul 22, 2018 at 21:05

2 Answers 2


Check adb devices. If no device shows up follow the steps below.

First, check to make sure USB Debugging is enabled. On most devices:

  1. Go into 'About Phone', 'About Device', or 'About Tablet'
  2. Find 'Build Number'. It's location varies from devices to device, but look for menus such as 'Software Information'
  3. Tap 'Build Number' until you see a message saying 'You are now a developer'. If you see a message saying something along the lines of 'This option has been disabled by your administrator', I'm sorry to say you will need to reset your device to use ADB. You could also talk to your administrator.
  4. Go back to the main settings page. At the bottom, you should now see 'Developer Options'. Tap it.
  5. A warning may display. Read it carefully, and decide at your own risk.
  6. Scroll until you find 'USB Debugging'. Tap it. You will see another warning. Read. Decide.
  7. Connect your device to your computer. Run adb shell. A dialog box will pop up asking if you trust your computer. Tap yes.

Congrats! It should now work.

If that doesn't work, try different cables, phones, computers, and try to find what is the problem. Google is, as always, your friend.


OK, I did it. Apparently I was using some old adb binary that came with app I wanted to use. After I installed the one available in repo, as suggested by this website, It now sees the device:

$ sudo add-apt-repository ppa:phablet-team/tools
[sudo] password for admin: 

 More info: https://launchpad.net/~phablet-team/+archive/ubuntu/tools
Press [ENTER] to continue or ctrl-c to cancel adding it

-- ciach
$ sudo apt-get update
Hit:1 http://pl.archive.ubuntu.com/ubuntu xenial InRelease

-- ciach
$ sudo apt-get install android-tools-adb android-tools-fastboot
Reading package lists... Done
Building dependency tree       
Reading state information... Done

-- ciach
$ adb devices
adb server is out of date.  killing...
* daemon started successfully *
List of devices attached 

$ adb devices
List of devices attached 
0123456789ABCDEF    unauthorized

-- click "Authorize" on the device
$ adb devices
List of devices attached 
0123456789ABCDEF    device

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .