2

This was the most recent article I found on it:

https://www.howtogeek.com/303489/how-to-disable-the-profanity-filter-in-google-assistant/

Problem is that the triple dot dropdown menu isn't there. I have an icon that looks like a new email message and one that looks like a compass needle. I've searched the settings for "censor" and "block" and there are no results.

How do I stop it from turning "fuck" into "f***" in Android 7? LG G5

1

The LG rebel 3 running Android nougat 7.0 there are a couple of paths to the Block offensive words toggle.

First it spelled f*** missing the k but then I manually typed in the word. When I tried by voice after that it was spelled properly and fully. The path's to the Block offensive words toggle are:

  1. /Language & Keyboard --> Google voice typing --> Block Offensive words toggle.
  2. /Google services --> Search, Assistant, Voice --> Voice --> Block offensive words toggle.
  • 1
    In Android 8 this is in General -> Apps & Notifications -> Default apps -> Assist & voice input -> Assist app (gear) -> Block Offensive words (toggle) (updated my phone since posting this) – jcollum Jan 8 at 1:11
0

On Android 7.1.2, I go to:

  • Settings
  • Language and Keyboard
  • Keyboard and Input Methods / Google Voice Typing

"Block offensive words" is 2nd from the bottom. I've tried toggling it successfully. This works for me when I use Google Keep.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.