I write my question in a search box (on stack exchange or wikipedia or Google.) when I press enter, it doesn't search.

This isn't a keyboard thing since I've tried swiftkey, android keyboard, Samsung keyboard, and swype.

It is an opera thing, since using default browser, the keyboard "enter" is replaced by a spyglass for search or a tick in a circle for "go" as expected. I've not tried any other browsers.

I only noticed this problem after upgrading my galaxy tab to 3.2...

  • There is no opera tag and I can't create one...
    – Seamus
    Feb 26, 2012 at 22:03
  • There is no opera tag because we have an opera-mini tag and an opera-mobile tag. There are some distinct differences between Mini and Mobile. Which are you using? Feb 26, 2012 at 22:39
  • Aha. I can't see the autocomplete options when typing on my galaxy tab... Opera mobile, and I'm using.
    – Seamus
    Feb 26, 2012 at 22:55
  • You should see autocomplete options in the mobile view, with Opera mobile -- but there's a delay. Feb 27, 2012 at 1:27

2 Answers 2


My solution for SO uses an undocumented feature (an easy trick when there's no documentation whatsoever): longtouch the search bar, add it as a search engine, and then use Opera's own search bar for such sites. A trick you may like with SO is to do this multiple times, then manage search engines, click on one of the SO 'engines', and modify it so that you can readily add e.g. [android] to your searches. It may feel like a workaround, but the result is more comfortable than what I was used to on desktop systems.


A software update fixed this problem. Must've been a bug in opera mobile.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .