2

How can I enable immersive/fullscreen mode in Termux?

I want to hide the bars at the top and bottom of the screen so that the entire screen displays the terminal.

In summary, I'm looking for either a configuration option for enabling fullscreen mode in Termux, without reconfiguring (or rooting) my device and without connecting an external device, or an explanation of what happened to the fullscreen option mentioned in some parts of the documentation, if it has been removed.

0
4

I could have sworn immersive mode was a feature of Termux... You can still use immersive mode via ADB (or root, if you have that).

Hide both status and navigation bar: adb shell settings put global policy_control immersive.full=com.termux

Hide status bar only: adb shell settings put global policy_control immersive.status=com.termux

Hide navigation bar only: adb shell settings put global policy_control immersive.navigation=com.termux

Turn off immersive mode: adb shell settings put global policy_control immersive.off=com.termux

1
  • I've seen references to a fullscreen option while Googling, but also references to it being removed. Not sure what's going on with it. Hoping not to have to resort to adb... a setting in a dotfile would be ideal. Have a virtual +1, apparently I lack the rep to give you a real one. – guest Jul 26 '18 at 8:57
2

The fullscreen mode was removed in December 2017 due to the claim of complication with the multi-window and translucent status bar & navigation bar.

This was reported in #507 - Fullscreen / immersive mode option is gone

I have noticed that fullscreen option was missing, I have looked at recent commits and it looks that it was removed from sources.

kracejic - Dec 14, 2017


Since it hasn't been mentioned why it was removed, here's the commit

Remove the fullscreen setting
Trying to use fullscreen doesn't work well in a multi-windowed world and makes using translucent navigation and status bars more complicated.

hyperpallium - Jul 28, 2018

0

Since v0.107 (around Feb 2021), the fullscreen mode was added back with a fix to the Extra Keys issue. This should be configured manually through the property file.

From Termux Wiki - Terminal Settings

The Termux terminal can be configured by creating the file ~/.termux/termux.properties. This file uses a simple key=value property syntax and allows configuring the properties listed below.

After changing the properties file the changes will take effect either by executing termux-reload-settings or by restarting the Termux app (closing all sessions and starting the app again).

FullScreen Mode

v0.107 added option to enable fullscreen mode by specifying:

fullscreen = true

Note: It is likely that with fullscreen enabled, the Extra Keys view may no longer be visible. To fix, enable this workaround:

use-fullscreen-workaround = true

Fullscreen may not work well for all devices so consider it unstable for now.


Related pull request and discussion: #1911 - Implement full screen and add FullScreenWorkAround to fix ExtraKeysView

-1

Volume Up+K → variant to toggle extra keys view

Reference : https://wiki.termux.com/wiki/Touch_Keyboard

1
  • 1
    Hi, after reading the wiki, I'm not sure if this is what the question asked. This looks like showing/hiding the "extra keys" row, while the question is asking about making the Termux fullscreen (without status bar & navigation bar). – Andrew T. May 22 at 3:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.