1

I have a Nexus 7 and a MacBook Pro running El Capitan (10.11.6). I just installed Android File Transfer (1.0.11) and connected my Nexus.

Result: Android File Transfer automatically opens, but says:

Can't access device storage.

Make sure your device is unlocked and "File Transfer" or "MTP" mode is selected.

I found Google's troubleshooting page, and updated Android as per the advice there. I'm now running Android 6.0.1 with security patch level August, 2016. I got the same result.

My device was unlocked and there was no notification on the device when I connected it.

I found https://android.stackexchange.com/a/125679/190389 and followed those steps, but found that MTP mode was already selected, so that wasn't the issue.

I tried with more than one USB cable; one dinky cable resulted in the computer not recognizing that the device was connected at all (i.e. the device charged but Android File Transfer didn't open automatically, and when opened manually it said no Android device connected). But the cable resulting in the error message above was a sturdy good one that I got from WASD Keyboards along with my high-end keyboard purchase.

How can I get Android File Transfer working?

0

After struggling a lot and checking many solutions off the internet, my issue turned out to be related to "turning off and on again" the SIP (System Integrity Protection) on my Mac. I did the following and it magically works again:

  1. csrutil disable (and then reboot) → ADB/Android File Transfer not working yet.
  2. csrutil enable (and then reboot) → ADB/Android File Transfer already working up to this point.
  3. csrutil enable --without debug → I've gotta do this because I'm using XtraFinder and want to make it work for El Capitan.

See if this resolves yours :)

  • I’ve never messed with SIP before, so doubt that is the cause; had you adjusted it previously? – Wildcard Aug 12 '18 at 15:06
  • Uhm yeah, because I'm using XtraFinder. But I guess it won't hurt to give it a try. The default state of the SIP is all enabled. – Glenn Mohammad Aug 12 '18 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.