1

Yesterday my Samsung Galaxy Note 2 froze I'd say. The phone was locked and when I attempted to unlock it, it didn't respond (black display, just the led blinking). So I shut it down with holding power button until it stopped, then tried to power it up. The phone stucked on the Samsung logo booting part.

Currently I can't even get there cleanly, my screen is stucked on the battery image e.g. when you plug in the phone when charging, but the logo is frozen (normally there is a gif showing a charging battery). When I go to recovery and choose to reboot the system (to normal mode, not recovery), I can get pass the battery image, but I'm stuck on the Samsung logo again.

I have Samsung's stock Android 4.4, rooted, with CWM recovery. I can get into the phone when in recovery mode (power+volup+home, ClockworkMod Recovery v6.0.4.3), but even through the recovery menu I get only Can't mount backup path. or E:Can't mount /sdcard when I try to e.g. backup the phone (at least to show whether the damn thing mounts). When I go to the section in CWM where I can attempt to mount (there is format also, but I haven't done it yet, most likely even won't work because of the mounting) these:

  • /efs
  • /system
  • /cache
  • /preload
  • /data

on each of the options I get only: Error mounting <...>.

When I try to wipe the cache, I get this:

E:format_volume: make_extf4fs failed on /dev/block/mmcblk0p12

When I try wiping dalvik cache, nothing appears in the log.

On each try to actually do something in CWM I get this in the log:

E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log

I can reboot to bootloader, but (perhaps obviously) adb doesn't connect to the device because it's not even showing in the list nor able to get it via adb usb.

I can get into the phone with adb only when in recovery mode, so I checked the default locations e.g. /data/data, /sdcard, /system and everything in there seems dead, nothing is mounted.

/

boot                 fstab.smdk4x12       sbin
cache                init                 sd-ext
data                 init.rc              sdcard
datadata             internal_sd          seapp_contexts
default.prop         lpm.rc               sepolicy
dev                  mnt                  storage
efs                  preload              sys
emmc                 proc                 system
etc                  property_contexts    tmp
external_sd          recovery             ueventd.goldfish.rc
file_contexts        res                  ueventd.rc
fstab.goldfish       root                 ueventd.smdk4x12.rc

/dev

HPD                    input               ttyGS2
__properties__         ion                 ttyGS3
akm8963                keychord            ttyS0
alarm                  kmem                ttyS1
android_adb            kmsg                ttyS2
ashmem                 link_pm             ttyS3
binder                 log                 ttySAC0
block                  mali                ttySAC1
bus                    mem                 ttySAC2
bus_dma_throughput     mobicore            ttySAC3
console                modem_br            tun
cpu_dma_latency        mtp_usb             tzic
device-mapper          multipdp            uhid
display_frequency      network_latency     uinput
dun                    network_throughput  ump
dvfs_response_latency  null                umts_boot0
ecryptfs               pn544               umts_csd
exynos-mem             ppp                 umts_ipc0
fimg2d                 psaux               umts_loopback0
fmradio                ptmx                umts_ramdump0
full                   pts                 umts_rfs0
fuse                   random              umts_router
graphics               rfkill              urandom
i2c-0                  rtc0                usb_accessory
i2c-1                  rtc1                vcs
i2c-12                 s3c-mem             vcs1
i2c-14                 s3c-mfc             vcsa
i2c-15                 s5p-smem            vcsa1
i2c-17                 snd                 video0
i2c-19                 socket              video1
i2c-21                 srp                 video11
i2c-22                 ssp_sensorhub       video12
i2c-3                  sw_sync             video16
i2c-4                  tspdrv              video2
i2c-5                  tty                 video20
i2c-6                  tty0 - 63           video3
i2c-7                  ttyGS0              xt_qtaguid
i2c-8                  ttyGS1              zero

~ # ls /dev/block

ls /dev/block
loop0       loop4       mmcblk0p12  ram11       ram15       ram5        ram9
loop1       loop5       ram0        ram12       ram2        ram6        vold
loop2       loop6       ram1        ram13       ram3        ram7
loop3       loop7       ram10       ram14       ram4        ram8

mmcblk0p12 is a /cache partition, however it's sometimes missing. I don't see the device (mmcblk0) there anyway, so perhaps it's just some quirk from CWM. I can't mount it to /cache or custom folder too:

~ # mount /dev/block/mmcblk0p12 /testfolder

mount /dev/block/mmcblk0p12 /testfolder
mount: mounting /dev/block/loop0 on /testfolder failed: Invalid argument

I tried to investigate where is the device I'm looking for (mmcblk0) and its partitions (mainly mmcblk0p16 i.e. /data) via dmesg:

~ # cat fstab.goldfish

cat fstab.goldfish
# Android fstab file.
#<src>                                                  <mnt_point>         <type>    <mnt_flags and options>                              <fs_mgr_flags>
# The filesystem that contains the filesystem checker binary (typically /system) cannot
# specify MF_CHECK, and must come before any filesystems that do specify MF_CHECK
/dev/block/mtdblock0                                    /system             ext4
      ro,barrier=1                                         wait
/dev/block/mtdblock1                                    /data               ext4
      noatime,nosuid,nodev,barrier=1,nomblk_io_submit      wait,check
/dev/block/mtdblock2                                    /cache              ext4
      noatime,nosuid,nodev,nomblk_io_submit,errors=panic   wait,check
/devices/platform/goldfish_mmc.0                        /storage/sdcard     vfat
      defaults                                             voldmanaged=sdcard:auto

~ # df

df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                   923748        48    923700   0% /dev
tmpfs                   923748         0    923748   0% /storage
tmpfs                   923748         0    923748   0% /mnt/secure
tmpfs                   923748         0    923748   0% /mnt/fuse

~ # mount

mount
rootfs on / type rootfs (rw)
tmpfs on /dev type tmpfs (rw,seclabel,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,seclabel,relatime,mode=600)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,seclabel,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
tmpfs on /storage type tmpfs (rw,seclabel,relatime,mode=050,gid=1028)  # this folder is empty actually (bad)
tmpfs on /mnt/secure type tmpfs (rw,seclabel,relatime,mode=700)
tmpfs on /mnt/fuse type tmpfs (rw,seclabel,relatime,mode=775,gid=1000)

~ # cat /etc/recovery.fstab

# Android fstab file.
#<src>                  <mnt_point>         <type>    <mnt_flags and options>
                            <fs_mgr_flags>
# The filesystem that contains the filesystem checker binary (typically /system) cannot
# specify MF_CHECK, and must come before any filesystems that do specify MF_CHECK
# data partition must be located at the bottom for supporting device encryption

/dev/block/mmcblk0p3     /efs                ext4      noatime,nosuid,nodev,journal_async_commit,errors=panic    wait
/dev/block/mmcblk0p13    /system             ext4      ro,noatime
                                 wait
/dev/block/mmcblk0p12    /cache              ext4      noatime,nosuid,nodev,journal_async_commit,errors=panic    wait,check
/dev/block/mmcblk0p14    /preload            ext4      noatime,nosuid,nodev,journal_async_commit                 wait
/dev/block/mmcblk0p16    /data               ext4      noatime,nosuid,nodev,discard,noauto_da_alloc,journal_async_commit,errors=panic    wait,check,encryptable=footer

/devices/platform/s3c-sdhci.2/mmc_host/mmc1     /storage/sdcard1    auto      defaults      voldmanaged=sdcard1:auto
/devices/platform/s5p-ehci                     /storage/usbdisk0   auto      defaults      voldmanaged=usbdisk0:auto

# recovery
/dev/block/mmcblk0p8            /boot                           emmc
defaults                recoveryonly
/dev/block/mmcblk0p9            /recovery                       emmc
defaults                recoveryonly
/dev/block/mmcblk0p10           /modem                          emmc
defaults                recoveryonly    

~ # cat /etc/fstab ~ # cat /etc/fstab

cat /etc/fstab
/dev/block/mmcblk0p12 /cache ext4 rw
/dev/block/mmcblk0p16 /data ext4 rw
/dev/block/mmcblk0p13 /system ext4 rw

I attempted to make a backup via CWM to the external card, but it failed I think on the first/fourth step:

/storage/sdcard1: Checking
/storage/sdcard1: Mounted
SD Card space free: 14983MB
Backing up boot image...
Error while backing up boot image!

Obviously the folder with the backup remains empty.

So to my questions:

  1. Is there ANY way how can I recover data from the internal SD card and/or from the (mounted) /data folder? I don't care what happens to the device, I only care about the data.

  2. Less important one. Is there any way how to recover the actual system to a working state even without recovering the data mentioned in 1.?

Edit: Any ideas?

  • 1
    Seems to me like a lot of mmcblk0p* special files are missing under /dev/block. I'm not sure on it, but it seems like your internal flash storage is broken. – confetti Aug 6 '18 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.