0

so I have a moto 4 plus running android 7 that I am having trouble with running twrp. I am following a guide to root it by unlocking the bootloader, flashing twrp (temporarily) and then flash Magisk-v16.0.zip. this is where I found this guide:

https://forum.xda-developers.com/moto-e4-plus/how-to/root-twrp-motorola-moto-e4-plus-xt1775-t3791064

I have one identical phone (I think they have identical build number) that I can do this without any problems. The other phone that I have problem with, twrp keeps getting stuck at "updating partition details." This happens when I try to do a back up so I have to skip it and try installing magisk.zip again and it got stuck again at "updating partition details." I am afraid if I try to turn it off now I may brick the phone.

I tried asking this at the forum where I got the instruction from but had no luck getting any answer. I am hoping to receive any guidance on this matter. Many thanks!

phone screen 1 phone screen 2

  • please wait for sometime, i have seen it take about 2/3 minutes to start install rom zip(with project treble ) in my redmi 3s. – Rahul Gopi Jul 30 '18 at 5:37
  • thanks. but it has been like this for 4 hours now. also the same way when i tried to back it up. it can never get past that – harvoni Jul 30 '18 at 10:18
0

As u mention: if the "Updating partition details..." take more than 4 hours: You have a problem.

As it's noted on the XDA OP, have u flash the "no-verity-opt-encrypt.zip" file ? Apparently it's necessary to completly disabling the forced encryption on your phone.

Try to flash directly the Magisk uninstaller zip, reboot in TWRP, and try again to flash Magisk v16.

  • thanks. so shut off the phone now? does it matter if i only flash twrp temporarily? i didnt want to flash it permanently because sometimes twrp hangs at the logo screen. what do i do first? flash the no encrypt.zip or magisk uninstaller first? many thanks again – harvoni Jul 30 '18 at 12:28
  • Ah u have only flashed temporary the twrp img file ok, so u should backup your stock recovery, install permanently/temporary the twrp img file, flash the no encrypt.zip file, flash the Magisk zip file and see if any error(s) occured.. – Rom Jul 30 '18 at 13:23
  • many thanks for your quick reply. i wish i found this forum first. you meaning backing up in twrp? i guess i have to flash no encrypt first because twrp will hang during backup (also at "updating partition details"). in fact i think anything that involves "updating partition details" by twrp will hang (not sure if it will happen during no encrypt installation as well). sorry i dont mean to ask so many questions. i rather ask questions first but was not able to get any answer early on. please bear with me. thanks. – harvoni Jul 30 '18 at 13:48
  • so update: I cannot get past "updating partition details" on anything. However, it looks like magisk is successfully installed because I now have root. So I am just wondering what does the "updating partition details" really do. Many thanks again. – harvoni Jul 31 '18 at 19:43
  • So if your Magisk installation is OK it's done for you, about the "updating partition details", it's generally when TWRP unmount partition, close files opened by any process,.. It can help if the installation script is in a "test stage", but Magisk isn't a test version :) – Rom Aug 1 '18 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.