7

I have an LG G6 running Oreo and whenever media is playing and a notification sound comes through something briefly lowers (not fully muted) my media volume. How can I stop this? I don't want notification sounds to change my media volume.

  • 1
    This is an awesome question. – tlhIngan Aug 5 '18 at 1:37
5

Updated Answer

I first thought that the OP was asking about modifying the behavior of the sources of the notifications which can be done in with finer levels than before using Notification Categories in Android 8.0 Oreo.

However via the comments, it appears that the OP wants to stop Audio Ducking from happening in the media player. Unfortunately this is a feature of the media app playing the music itself and requires the developer of the app to configure. See similar question: Prevent music volume from being lowered when using turn-by-turn navigation

Original Answer

In Android 8.0 Oreo the App can now have Notification Categories

Check the notification setting screen in:

Settings->Apps & Notification->[App Name]->App Notifications

Clock App App Notifications Screen

For the App(s) that are interrupting see if you can either disable sound or adjust the priority to one which suits your needs.

  • That seems like only a stopgap measure. What about in cases like receiving texts? I need to be able to receive those sound notifications BUT I don't want them to effect the volume of my music. – KD8NXH Aug 4 '18 at 2:45
  • 1
    You are referring to Audio Ducking. The app that is playing music handles the ducking. See: Prevent music volume from being lowered when using turn-by-turn navigation – Morrison Chang Aug 4 '18 at 3:10
  • Make thst comment into an answer and I'll accept it. – KD8NXH Aug 5 '18 at 2:11
1

Rocket Player, is a music player that will let you choose between ducking and pausing, and will allow you to disable it completely, (The setting is under Settings->Sound->Audio Focus->Temp Focus Action)".

It does give the option to IGNORE all other apps. Just tested it: maps, camera shutter sound, notifications - all make sounds but no longer "duck" (more like stutter!) my music, listening via 3.5mm right now but should be same for BT.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.