1

Before it became problematic, the bootloader on my Moto Z was unlocked, developer options were on and so was USB Debugging. Then a friend tried to root it and that's when my problems began.

Now, when I connect my Moto Z to my PC the usual "USB connected" sound is heard and the android device (Moto Z) appears without error under Windows Device Manager.

As far as I know, my major issue is that the phone only connects to the PC in charging mode. I've tried various cables, including one that specifically claims to be for data transfer. I also have the correct universal drivers installed. These were installed after I removed the Motorola drivers (they didn't seem to work, either).

Any idea how I can get my Moto Z to communicate with my Windows 10 PC so I can transfer the necessary files to the phone to get it out of this "soft-brick" mode?

Thanks.

John ODwyer

  • What kind of USB connection were you trying to use? At the bootloader screen, only fastboot will connect to the phone: you can't use adb or transfer files via MTP. That's entirely normal. – Dan Hulme Aug 8 '18 at 7:56
0

have you tried to connect in bootloader mode? hold power button plus volume down when device turn on untill it boots into boot loader and from there flash TWRP then you can transfer files via TWRP. you gonna need ADB tools tho.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.