2

I have an android phone and an android tablet. Both not rooted. I want to use adb as host on the tablet and as client on the phone, using an USB-OTG adapter.

I downloaded connectbot as terminal emulator on the tablet. I also downloaded the ARM binary for adb onto the tablet. However I'm getting the following error when I try to execute the binary:

user@tablet:/storage/sdcard0/download $ ./adb-arm-binary.bin devices
/system/bin/sh: ./adb-arm-binary.bin: can't execute: Permission denied

Is there anyway to get ADB as a host to run on an android 4.4.2 tablet without root?

OR: Is there any way to root said tablet without a PC?

The whole reason I need this is because I need to access dumpsys logs from the phone but I do not have a PC or laptop. A way to get dumpsys logs directly on the phone without root would suffice too, but AFAIK dumpsys is impossible to access for non-system application.

migrated from superuser.com Aug 6 '18 at 21:08

This question came from our site for computer enthusiasts and power users.

  • if somebody wants to root their phone, they'd use adb and run various commands, so no you don't need root to use adb. I can't comment much on the rest. But, you can download a terminal app and run linux commands like ls, see how far you can see without 'root', you may need to 'root' your phone, to see what you want to see, I don't know. You won't need a PC or adb to download a terminal app and ls and look around and see limitations e.g. try cd / see if it works – barlop Aug 7 '18 at 0:24
  • It's trickier than that. I need root to run adb as a host on android. I can't use a terminal app on the phone because they don't have the permission to use dumpsys, only system apps do. I need root to make an app a system app. – confetti Aug 7 '18 at 0:28
  • 1
    Just tried on my own device; dumpsys works as long as the app has root, no system application required. The permission problem is, the entire sdcard is mounted so that nothing on it is executable, so you can't run any binary from it. – Andy Yan Aug 7 '18 at 0:47
  • Thanks for that info, I only got my information from google and XDA-devs. Sadly, I don't have root on that phone. It's a motorola E4 by the way. AFAIK no way to root it without a computer. – confetti Aug 7 '18 at 1:02
  • 1
    Ask a new question please and self-answer this one on how you rooted your Android device. – Firelord Aug 7 '18 at 8:18
2

Alright, I got it to work, here is what I did:

1. Rooted the tablet

I was able to use kingroot to root the tablet.

2. Install adb on the tablet

I basically followed these instructions, however the files in the OP there are outdated and not downloadable anymore. So I used a file someone posted much later in that thread, this file seems outdated though, but I'm unsure about that and will open a new question about that.

  1. Downloaded the adb.bin file on the tablet (in /storage/sdcard0/Download)
  2. Downloaded Connectbot from f-droid and setup a local shell connection to the tablet
  3. Ran the following commands (everything after (including) the # is just a comment)
su # gain root priviledges
cd /storage/sdcard0/Download # change working directory to download folder
mount -o remount,rw /system # re-mount /system partition so we can write on it
cp adb.bin /system/bin/adb # copy it to bin folder so it's accessible as a command
chmod 755 /system/bin/adb # make it executable
  1. Rebooted tablet

3. Enjoy adb as host on android!

This worked for me and got me an executable adb running. I still can't connect to my phone but since this is another issue I opened a new question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.