I used to access the internet on my notebook by tethering it to my android mobile phone. However recently this stopped working. Even though the notebook was tethered to the phone there was no internet access. Changing phone settings did not help.

3 Answers 3


On googling I found that my mobile service provider recently disabled internet access over tethering. This can be fixed by the following the steps described here.

  1. Enable USB debugging on your android phone (Settings > Developer options > Enable USB debugging).
  2. Download adb.exe from here and follow the steps here.
  3. Connect the phone to your computer using USB cable.
  4. Open command window in the folder containing adb.exe.
  5. Type: adb devices -l (this will list your device model).
  6. Type: adb shell (to enter in your mobile's shell).
  7. Type: settings put global tether_dun_required 0.
  8. Reboot your phone and you're done!

After a lot of headache and trying everything, including Martin's answer (but I got no permissions error when I tried settings...), this solved the problem for me:

Go to Configurations > Wireless & Networks > Mobile Networks > Access Point Names, make a copy of the default selected APN (you probably need to input a copy all by hand after going to "New APN" in a menu), and then in the copy add ,dun to APN type (if it was default, make it default,dun).


I have resolved this issue by changing the APN in mobile. Go to your cellular network -> choose new APN with the same configuration of your selected one or create new APN with the same configuration of current one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .