0

Please see this question for background information.

Problem:

Whenever I run adb devices it says Error: device offline - This appears even when no device is connected at all. It won't even let me start the adb server. Therefore solutions like "run adb kill-server first" won't have any affect.

Things to note:

  • This is adb on another android device. I can not "re-install the android SDK platform" or something like that. It took me a long while to find the ARM binary for adb that works.
  • From googling around, I suspect it might be that the adb binary is outdated, however it seemed to work recently for other people on XDA-devs. If anyone can provide me with a newer version of adb as a binary that will run on an ARM platform (android), I'd be happy to try it out.
  • Yes, I do run adb as superuser (root). Other commands (like adb --help work).

The tablet runs android 4. The phone runs android 7 but that shouldn't matter since even without anything connected I can't even start the adb server on the tablet.


Edit: Using the adb binary from here solved the error, but presents me with this now:

# adb devices
List of devices attached
* daemon not running. starting it now at tcp:5038 *
* daemon started successfully *
** daemon still not running
error: cannot connect to daemon at tcp:5038: Success
  • Please clarify. If you already have gained root access, why are you bothering with adb at all? You can use dumpsys command on that tablet using root, save the output and upload or share it with other device. // BTW, You can use adb.bin from here. Use Termux app and install busybox in there. Afterwards, copy adb.bin in its HOME directory, set executable bit on the binary and then run it. – Firelord Aug 12 '18 at 17:04
  • I need to use dumpsys on my phone (which I can't root), that's why I need an adb host. I sadly don't have a PC at the moment. I'm going to try your latter steps now. – confetti Aug 12 '18 at 17:14
  • Did you give RSA authentication to it? Offline is shown often when device is found but not authenticated. – Firelord Aug 12 '18 at 17:24
  • I couldn't get to that point yet. It shows that error even when nothing is connected and it doesn't even start the adb server. Trying what you suggested now. Can you tell me how to install busybox in termux? Online sites say it's already included and I already have regular busybox installed, is that enough? – confetti Aug 12 '18 at 17:42
  • Run pkg install busybox in Termux. BTW, you can use adb.bin from here as well. github.com/Magisk-Modules-Repo/adb-Installer/tree/master/bin (Use adb.bin not adb binary, if you must) – Firelord Aug 12 '18 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.