0

I recently reinstalled WhatsApp because it stopped working. Then, I restored the Google Drive backup. For this backup, I used my primary Google account. Restoring worked fine.

However, after restoring the backup, no new backups would work. It always just got stuck at some percentage of progress. After many failed attempts of canceling the backup after hours of being stuck at the same percentage, I added my secondary Google account to my phone and chose it as WhatApp's backup location. It then went on to make a 2.3 GB backup to the secondary Google account (according to the information WhatsApp stated). This backup again got stuck. Repeating it several times always made it get stuck at a higher percentage of progress.

Eventually, I gave up and deleted the backup in Google drive (secondary account). I noticed that my secondary account only used a few hundred MB in total, according to the information found in the bottom left corner of the Google Drive website.

After deleting the backup, I started another backup. WhatsApp showed that it already completed 2.3 GB of 4.6 GB right from the beginning. This got stuck again at 99%. After deleting the backup again and starting it again, it now started at 4.6 GB of 6.9 GB, apparently always increasing by 2.3 GB.

What should I do to perform a full backup?

  • Is your whatsapp updated? Next, try clearing the cache of WhatsApp - I don't know how this helps but is recommended – beeshyams Aug 15 '18 at 15:16
  • According to the Play Store, all apps are up to date. I already forced-stopped WhtasApp and cleared its cache prior to the last attempt but I'm going to try again. – UTF-8 Aug 15 '18 at 16:24
  • Have you tried reinstalling WhatsApp itself? – SSS Aug 15 '18 at 21:13
  • @SSS If i were to do that, wouldn't I lose all my messages? – UTF-8 Aug 15 '18 at 21:15
  • Whatsapp chat messages are locally backed up to /sdcard/WhatsApp/Databases, make a copy of the folder just in case. – SSS Aug 15 '18 at 21:41
0

The exact same happened to me, it would never finish uploading the backup to Google Drive and in every new attempt it would tell me that the backup size was bigger, start the upload and stop somewhere between 97% and 99%.

The only difference is this started happening spontaneously, it was successfully making and uploading backups every day and then one day, out of the sudden it couldn't finish uploading it.

After trying many of the suggestions that I found all over the Internet, like force stopping WhatsApp, clearing the cache, set it to use another Google account for backups, nothing helped.

At the end, the cause was the same issue pointed out in your last comment, I had a few corrupt 0 byte media files within WhatsApp's Media/ folder that couldn't be read, moved, copied or deleted: Operation not permitted.

I don't know how did that happen, but the best way I could get around it was to use a terminal App and run Linux commands for copying all non-corrupt files to a new folder:

cd WhatsApp
mkdir MediaCopies
cp -r Media/* MediaCopies

It will throw errors about the corrupt files but continue copying the good ones.

After checking MediaCopies/ looks right and contains all files then:

mv Media Media~
mv MediaCopies Media

Then open WhatsApp, poke around open pictures, videos, etc. and finally:

rm -rf Media~

It will fail to remove those corrupt files, but at least you won't have the rest of the files duplicated.

And voilà! No more issues uploading the backup.

  • Of course I can't test this anymore but it looks like it would work, so I'll accept this answer.. Thank you for writing it down for others. :) – UTF-8 Jun 24 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.