I have installed the custom ROM from TeamWin recovery mode for android 8.1 (don't judge 😋). Everything was installing fine with no errors but then I then installed Gapps, it then told me there is not enough free space on /system partition. How can I free up some space to install Gapps?


Check this log file!

  • Use a smaller Gapps package...
    – acejavelin
    Aug 16, 2018 at 0:04
  • In general on a custom ROM it is recommended to use the GApps nano package. Otherwise you will have earlier or later every app installed twice (for each GApp one on the system partition and one updated app on the user data partition). Just use the nano package and download all GApps you want from PlayStore.
    – Robert
    Aug 16, 2018 at 12:50
  • @acejavelin I installed the pico version and still has the same error.
    – LtMuffin
    Aug 16, 2018 at 14:31
  • Did you perform a CLEAN install? Meaning, did you wipe system, data, and caches prior to flashing? If yes, then I would suggest going to your maintainer of the ROM or the official support thread for the ROM on your device, they should have a recommended Gapps package
    – acejavelin
    Aug 16, 2018 at 14:42
  • @acejavelin Yes I wiped the tablet clean before flashing. I'll check the forums. Thanks
    – LtMuffin
    Aug 16, 2018 at 14:56

1 Answer 1


I guess you have two way.

  1. Go to Custom Recovery and wipe /System partition Then, reinstall Custom ROM. (Maybe /System partition have problem and after doing this step that's fixed. )

  2. Download Nano Variant of gapps and install on your device. It's very light. Go to Play Store and install other Google Application. (If you install Google Application from Google Play, they installed on /Data partition and /System partition be free.)

  • After I tried this, it still didn't work. I think I give up at this point.
    – LtMuffin
    Aug 16, 2018 at 23:06
  • @Leon185 Test stock rom and do steps again.
    – M. Rostami
    Aug 19, 2018 at 7:01
  • How do I do that?
    – LtMuffin
    Aug 19, 2018 at 20:39
  • What is the model of your phone?
    – M. Rostami
    Aug 20, 2018 at 6:23
  • Take a look at the log, I edited the question to add a log.
    – LtMuffin
    Aug 20, 2018 at 10:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .