2

I have a Xiaomi A1 with Android on it and I use my Samsung MicroSD Card Evo+ 128 GB, as an internal storage. For no reason, it's stopped working and asking me to format it. The issue is, the device and even my laptop with Linux or Mac can't format it. I can't use it. I tried to do it with GParted (See screenshot below)

This is what I get when I run : sudo fdisk -l

    Disk /dev/sdc: 119,8 GiB, 128579534848 bytes, 251131904 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5875CF08-49DC-47BC-BEBF-A19D422163EA

Device     Start       End   Sectors   Size Type
/dev/sdc1   2048     34815     32768    16M unknown
/dev/sdc2  34816 251131870 251097055 119,7G unknown

Screenshot GParted about the SD Card

I tried to follow the path of this person but in vain : Decrypting Android M adopted storage

Edit : First of all, thank you @DanHulme for your quick reply. When I try to format it with my Android phone (whether as an internal or external storage), it gets stuck on 20% formatting then I get this message : command '16' volume partition disk:179,64 private' failed with null

Any help would be very appreciated. Thank you for your time,

0

command '16' volume partition disk:179,64 private' failed with null

Figure 16 may be replaced by 8, 12, 18 and others, so does 179,0 appearing in the message. So, the general problem is that they're unable to format an SD card due to volume partition disk failed with null.

The reason why does "volume partition disk failed with null" error appear and Android phone owners not being able to format the micro SD card on their phone is most probably because the card is partially damaged or corrupted, and it needs to be fixed in order to make the phone read or recognize the card.

Short and Simple fix:

You put your SD card into a Windows computer and used file explorer to format it as FAT32 you could put it back into your phone, it should work.

For more details and data recovery visit: https://www.easeus.com/resource/volume-partition-disk-failed-with-null.html

  • Hi, @Aashish, thanks for your answer. Unfortunately it's not as simple as you think. On Windows OS 10, my USB Drive is seen as two separate partitions. The process of formatting isn't working as we could think : Windows could not format the disk . That's why I went to Linux OS to get more advanced tools. Any thoughts ? – Squick' Mar 31 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.