0

My Huawei P8 should only ever sync mails whenever I open the mail app and manually ask for it. This is for mental hygiene to keep my spare time free of any unwanted distractions.

So I've disabled any sync schedule in the account settings of the mail app:

enter image description here

I have to keep the "Sync email" switch on as otherwhise sync wouldn't work at all anymore.

I'd expect that there's no automatic sync at all anymore. But still it happens every 1 or 2 weeks that I get a notification on my home screen even though I did not touch the mail app:

enter image description here

That's quite annoying. How can I really disable automated sync and make it only check for new mails when I want it?

It shouldn't be related but I've "secured" the mail app with the built in "App lock" feature with a PIN.

  • Phone model: HUAWEI GRA-L09
  • Build number GRA-L09C432B520
  • EMUI version: 4.0.3
  • Android version: 6.0
  • Mail account: IMAP on custom server
1

I ran into the exactly same problem years ago. I "fixed" it by ignoring the default mail app and using a third party mail app (AquaMail).

Anyway the default mail app is usually no longer included on new devices (Google stopped development). Therefore earlier or later you have to move to a different mail app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.