1

I was using Titanium Backup previously. It was working fine when I rooted my device before a month. But Because of some problem in my phone I again rooted my device, and now when I install this app, I'm getting error 504.

I tried so many things: I tried with different internet connection with high speed. I cleared Google play cache/ services cache clear data etc. I reset app preferences. I downloaded apk from apkmiror. I tried with signed testing APK. I tried with the edit common files like change app name.

  • Need to find out what error 504 is. Get in touch with the developer. – user202027 Aug 21 '18 at 13:08
  • I guess you're getting this error from the Playstore app? Then see: Error 504 when downloading apps from Play Store? – Izzy Aug 21 '18 at 15:34
  • @Izzy Thanks for quick reply, but I almost read all the post. Please give me another solution. – Pooja Singh Aug 21 '18 at 16:01
  • @SiXandSeven8ths Can't install the app - this is the error. What should I do? Can you help me buddy? – Pooja Singh Aug 21 '18 at 16:08
  • 1
    If you have a computer available, you could try Raccoon to download the APK and manually installing it (assuming Playstore is at fault). You could also use Yalp Store to install apps from Playstore directly, bypassing the Playstore app. – Izzy Aug 22 '18 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.