1

I have a Samsung Galaxy S5 G900H. It had the stock ROM, and is quite old and slow, so I was asked to put something newer on it, and I got LineageOS.

As my previous experiences with Samsung phones, the usual trouble occurred, with USB communications failing for no reason, getting drivers, messing with ADB, etc.

This time however I got to a stump - it simply won't mount the cache partition. I have installed the TRWP of this phone (k3gxx) with Odin, and even tried 3 different versions. The cache can never be mounted, not to format it nor to actually install the ROM, and since other things were formatted before the recovery got stuck on the cache, the phone is now bricked, as far as I could tell.

Googling only resulted in answers such as "can't mount cache? go into recovery mode, mount cache, and clear it", but I am not sure I can follow the logic of mounting the cache to fix the problem of not being able to mount the cache.

Fastboot of course cannot help, since this is a Samsung phone.

I can freely get into Download and Recovery modes.

Is there anything actually left to do?

  • I don't have access to said phone right now, but hopefully I will have soon enough. I'll try doing what you wrote then, thanks! – user2503048 Aug 24 '18 at 10:33
1

Format the cache partition, that will help you to mount later.

  1. Just go for Wipe menu from TWRP home screen and select cache. It will show same error but format will be completed.
  2. Then select Mount menu from TWRP and select cache. It'll be mounted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.