0

I know this is probably not the right place to ask this but I am out of ideas.

Me and my girlfriend arrived in a hotel yesterday with open networks for us to use. So no splash screen or login. The problem that I am facing is that I am able to connect to the network but I can't seem to use Google to search things. It gives me "You're offline" without any additional information. However I am able to receive whatsapp messages and use some other apps like Facebook.

I have tried everything that I can think of and have been using mobile data to Google that problem for a few hours but no result. The weird thing is that when I connect to like a restaurant wifi everything works like it's supposed to. In the hotel everyone can use wifi expect me...

For those wondering I am using a Oneplus 3 and my girlfriend is using an iPhone.

Thanks in advance for any assistance! If additional information is required please let me know.

migrated from superuser.com Aug 23 '18 at 19:01

This question came from our site for computer enthusiasts and power users.

  • Do any other browsers work? Have you checked your proxy settings on the computer? Have you made sure you don’t have a static IP configured? Maybe your computer is infected with a virus that is redirecting web requests through malicious servers which are blocked by the hotel. This isn’t really the forum for drawn out troubleshooting help. There is a basic set of steps to troubleshoot any network connection. Check your IP info, check your DNS servers, test if you can resolve hostnames, find out if you can ping the gateway and then other internet hosts like the DNS servers. – Appleoddity Aug 23 '18 at 4:32
  • It smells a lot like the hotel has a proxy that's not configured correctly. Frustratingly, its something the hotel should tell you about but most staff won't know about – Journeyman Geek Aug 23 '18 at 7:52
  • 1
    Are you sure there's no splash page? I've seen this quite often. You have connection through apps, but can't access the internet directly. Once you login through the splash page, it'll work fine. – CustomX Aug 23 '18 at 8:28
  • Thank you for all the replies. I am sure there is no splash page because my girlfriend never got one either. The problem seems to be dns related. Whenever I connect to the wifi I can use Google for like a minute to search and then it stops again. Is there a way for me to fix this? – J.Rommers Aug 23 '18 at 14:09
  • Try connecting to a http site. The router might be trying to reroute your traffic. neverssl.com – Burgi Aug 23 '18 at 15:27
0

Try this:

  1. Make sure if it is a DNS resolution issue, Just use the IP of Google to check if we can connect. 74.125.24.94
  2. We can see the IP configuration of the network in our mobile. In Android, (I don't know what is yours, only in mine),Open settings-> wireless network-> click the ! of the wireless you connect-> network information, we will see DNS, Gateway, IP address, mask, and so on. Check if they are all correct.
  3. Then you can check if you have static settings in the static IP in the ! as well as network information.
  4. We can also try to set up a static IP to see if it works.
  5. Finally, we can also try to clear the network and re-connect again.
  • Hi, thank you for your suggestion. I tried the solutions that you gave me but non of them have worked. As stated above on my comment I seem to have a dns problem. I am using the Google dns since that is default on my phone. I have no way of changing this as far as I am aware. The weird thing is that when I go to a restaurant it all works fine. If you need any information please let me know. Thank you for your time! – J.Rommers Aug 23 '18 at 14:13
0

I'm not sure your problem is related to DNS, some networks will not let you forward DNS to an outside network. You may have to point it to the gateway device on the network.

In Android:

Open the Settings on the device.

Select “Wi-Fi”.

Long press your current network, then select “Modify network”.

Mark “Show advanced options” check box. Change “IP settings” to “Static” Add the DNS servers IPs to the “DNS 1”, and “DNS 2” fields.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy