1

I'm using Lenovo A7000 with Lollipop and I can't create new folders on SD Card. Attempt to create folder on SD card always end with error, however, android phone is not going to tell me what error it is. Attempt to use ADB from ubuntu terminal ended with lines below:

#Attempt 1
garrom@GarromMachine:~$ adb shell mkdir /storage/sdcard0/test_folder
mkdir failed for /storage/sdcard0/test_folder, Out of memory
#Attempt 2 with alternative folder path
garrom@GarromMachine:~$ adb shell mkdir mnt/sdcard/test_folder
mkdir failed for mnt/sdcard/test_folder, Out of memory

However, obtained error message is not somehow helpful because I have exactly 12362047488 bytes of free space. That is more than enough of space for empty folder. Even stranger, I can create or manipulate files just fine. I already tried formatting from phone itself, which is useless because phone format my SD card to fat16 which is obviously not good for 16Gb big SD card. I tried to format from Windows using Mini tool partition wizard and from Ubuntu using GParted, always same result,except formatting from phone but fat16 is too small and I had using Fat32 before without problems. I was using same SD card in same phone with same format before OTA update bricked my phone and I was forced to wipe out everything and flash in stock rom. Does someone know, how to be able to create folders once again ?

After further research i noticed it sometimes let me create folder and sometimes not ... Thinking about it, it looks almost like writing from Ubuntu(XFce, Thunar) temporarily disable ability to create new folders. I have two partitions on my sd card. one is named DATA(fat32,11.5Gib) and is meant to be my personal storage, second one is named APPS(ext4.9Gib) and is meant to work with App2SD app. I had same setup before without any problems, except, I was windows user before, I was writing files to sd card via usb cable from Windows before I started using Ubuntu....... but I was writing files from ubuntu as well before OTA update bricked my phone and I had to flash in stock rom.

This whole problem is generally weird...

  • 2
    You are describing the problem with Ext, SD but the commands used are for internal memory. sdcard0refers to internal storage and external memory is referred to either by sdcard1or volume serial number. See [this question and my comment] (android.stackexchange.com/q/189104/131553). You need to try to make the folder on the storage thus identified - now you are making on internal SD or phone storage – beeshyams Aug 27 '18 at 23:22
  • @beeshyams I forgot to mention it but in storage settings I set sd card as default write location. I recognized my sd card in app FX Browser (due to its size and files on it). Attempt 1 was with path given by FX Browser meanwhile in Attempt 2 was used path found via. root browser feature of FX Browser. Setting SD card as default write location makes it internal SD card – Jacob Aug 28 '18 at 9:06
  • Setting SD card as default write location makes it internal SD card- not sure of that. Try removing that condition and test. If it works then your question needs to be reframed in a big way – beeshyams Aug 28 '18 at 10:02
0

Is possible to destroy SD Card by repeatedly flashing stock ROM and repeatedly rooting ? Yeah, apparently yes. It looks like my SD card was destroyed. Next time, if you are going to flash or root something, remove your SD card first..... yeah, I'm stupid, it is obvious step to do. Problem solved by buying new SD Card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.