Google Maps was set as the default maps app on my Samsung S8.

I went into settings-->apps-->Maps-->Clear Defaults, and now it says "None set as default".

However, in Calendar when I click on an address - it will launches Maps and doesn't ask me to choose a default. I also have Waze installed ... so why aren't I asked to choose a default again?

  • See if clearing cache of calendar helps. Or Try to set up default with this app play.google.com/store/apps/… – beeshyams Sep 1 '18 at 14:17
  • Maybe something to do with "Open links by defaut" e.g mapy.google.com etc, play around with these settings and see if it solves the issue – xavier_fakerat Sep 2 '18 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.