0

My phone is kept always on vibrate mode. When the screen is on and I get an SMS I can see the pop up notification and that's fine. Problem is when the screen is off - SMS sender name is read out aloud " Message from [sender name]" preceded by two long vibrations

I find this highly annoying sometimes and found no setting to mute this ( to replicate screen on behavior). I don't want to activate DND mode because I want to know that I have a text message waiting to be read via vibrate buzz

Surprised to see that no one complains of this on the net so obviously no solution ( Imagine your phone is on vibrate in a meeting but your phone announces to the world message from AXAIRNF or some embarrassing contact name) I tried automation, some Xposed / Magisk modules but none worked

Edit These additional attempts didn't help

  1. Switching off the notification of SMS app

  2. Trying alternate apps such as Textra etc

  3. Putting the device on low ringer / notification volume when screen is off

  4. Suspecting Text-to-Speech to be the culprit, killed that service when screen is off - no luck

Any solutions # including rooted means?

Mia1 stock 8.1 rooted with Magisk and Xposed (had same problem on 8.0 too). Stock Messaging app


# If you want to suggest automating, please stick to MacroDroid (don't want to add another automation app just for this). Gravity Box doesn't help. If your solution involves an alternate messaging app, it should be good at blocking spam SMS / be able to control reading of sender name(Textra already tried)

  • 4
    Is this a Xiaomi-specific thing? None of my phones have ever done this. – Dan Hulme Sep 2 '18 at 17:03
  • @DanHulme Possibly as I don't have any other device to check. Also probably the reason, it's not on net. Search on Xiaomi forums didn't help – beeshyams Sep 2 '18 at 17:06
  • 1
    Have you checked Accessibility --> Talkback --> settings --> Speak Caller ID? OnePlus seems to have that as well. But there it was Sound About, which apparently has such a setting in its "Alert Behavior" section (settings). – Izzy Sep 2 '18 at 19:12
  • 1
    I have similar option on my Motorola device. It is Talk to me under Moto voice. Using this setting device will read loud calls and texts when you are in particular location or in driving mode. – Rahul Gopi Sep 2 '18 at 22:26
  • 1
    Textra is a good messaging app which works well for both blocking and silencing certain contacts. I don't have a Xiaomi device at my end so there is not much I can help with. :( – Firelord Sep 3 '18 at 5:13
2

It had nothing to do with the device settings (but OS bug )

It was a macro misbehaving and reading out for any contact rather than chosen contacts (since the device is always on vibrate wanted audio alert for text messages from chosen few).I never suspected this since a similar macro for incoming calls was working fine

Edit: Shared logs with the developer who confirmed that it is an OS bug

My code in simple terms does a look up on the number in your contacts database and then when it matches it requests the ContactsContract.PhoneLookup.DISPLAY_NAME....your device OS has some kind of weird issue where it doesn't return a sensible name.

and hence it was getting triggered universally for any contact

  • Stupid of me not to figure this earlier and waste time (mine and other's). Interestingly this macro works fine on Marshmallow so something has changed – beeshyams Sep 6 '18 at 17:03
  • 1
    +1. How did you find out it was a macro to begin with? – Firelord Sep 6 '18 at 22:45
  • @Firelord: Thanks. Pure chance. Was going through Macrodroid system log for something else and saw this activated, when they're was no reason. Something had changed I think in the way SMS are detected because same version of MD on MM works fine – beeshyams Sep 7 '18 at 2:23
1

Some phones have a drive mode where the notifications are spoken. You might have a shortcut button from the pull down settings or go into the talkback settings and it should be near the bottom. If not a drive mode then go into talk back settings , tap verbosity, then unselect speak when screen is off. See if that is the answer.

  • Thanks. I don't have drive mode on my phone. All talk back settings are disabled and there isn't verbosity option any way – beeshyams Sep 6 '18 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.