9

Patient:

  • Xiaomi Redmi 4 Prime
  • MIUI 10 v8.8.23 beta by xiaomi.eu
  • Android 6.0.1

What happened:

  1. Annoyed with Facebook app burning my eyes, and unofficial mobile wrappers being generally slow and annoying to use, I installed a modded Facebook apk, one with black theme.
  2. It was working perfectly fine, better than any unofficial app I had. The only annoyance was constant "WE DOWNLOADED NEW VERSION UPDATE NOW!!!"
  3. Meanwhile, I decided to switch from SuperSU root to Magisk, since I've heard a lot of good things about it, and it can hide itself from apps like Pokemon GO which I always wanted to try (turns out PokeGO still detects root, go figure ¯\_(ツ)_/¯ )
  4. I disabled AdAway, restored stock build.prop file, unrooted through SuperSU app, updated the ROM and flashed Magisk
  5. That's when shenanigans started. Tapping the modded Facebook app icon was launching Sesame Shortcuts widget instead.
  6. I held the icon, uninstalled, and it (seemingly) got rid of both modded Facebook and Sesame Shortcuts.
  7. Here's where shit gets real. I tried installing:
    • Official Facebook app from Playstore (error 505)
    • Current Facebook app from apk (error parsing the package)
    • Older version of the Facebook app from apk (error parsing the package)
    • The modded, dark version Facebook app from apk (error parsing the package)
    • Facebook Lite from Playstore (error 505)
  8. Of course, I tried a few methods to solve it, which didn't work:
    • SD Maid complete scan and clean
    • Cleaning Playstore and Play Services files
    • Uninstalling Playstore updates and updating it
    • Switching Google account
    • Wiping Downloads Manager files
    • Restarting the phone
    • Using Solid Explorer with root permissions to look for any leftovers and deleting them (two empty com.facebook.katana folders was all there was
  9. At this point, I haven't tried (and would rather not try):
    • Factory reset
    • Reflashing the ROM

I'd be grateful for any help.

  • 8
    This is a well-conceived, and a superbly-written question. It demonstrates exhaustive effort by the user to correct the problem without just tossing it into the laps of the readers of this stackexchange, which seems to be the current climate. I would vote this up twice if possible, as an exemplar to be followed. – wbogacz Sep 4 '18 at 17:57
  • 1
    Honestly, you have done about everything I can think of to correct this error. As much as you don't want to, I think the next step would be a total clean flash... Wipe everything and reflash the ROM, Gapps, and Magisk, and then start clean. – acejavelin Sep 4 '18 at 23:36
  • My guess is that removing SU was not properly done. Try flashing this zip which removes SU totally and then go through remaining steps – beeshyams Sep 5 '18 at 1:37
  • 2
    Yes, that's the best now and you can self answer your question and congratulations on making a good start here. Continue to contribute to this site :) – beeshyams Sep 5 '18 at 3:16
  • 1
    Now that I look at it, TWRP shows Failed to to mount /system (Device or [something] can be busy) in red, buth during uninstalling and installing Magisk zip. Could that be messing with the process? – Angius Sep 5 '18 at 3:19
1

I've had issues installing apps after tweaking stuff before. I was sometimes able to resove it with pm set-install-location 0 in the terminal emulator (executed as superuser obviously). Though after reading through the comments, it seems like the problem could be more deep then this. I'd also suggest to switch back to SuperSU and see if the problem persists, just like @gamermane-Marsh suggested.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.