I have a phone that is bootlooping after a power failure + battery depletion during system encryption. How it got bricked isn't important here, the trouble is that I can't get into the recovery mode. Usually turning on the phone¹ via Volume Up+Power will enter recovery mode. I had TWRP flashed as the recovery and Lineage OS as the ROM. Now it does not respond to that keystroke.

Also generally one could boot to the system and run adb boot recovery, but with the system not booting that is not an option. I can however use Volume Down+Power to enter fastboot mode. I've tried reflashing the recovery image from fastboot, but it still does not respond to the key sequence. Using fastboot reboot tries to boot to the system. How can I get into recovery mode?

¹ In my case, a Levovo K6 Note/ K53a48 (karatep), but not really relevant to this question.

  • after lots of attempts, power off + volume up worked for me
    – makislog
    Apr 16, 2019 at 15:17

1 Answer 1


(Self answering here because I only found this answer after hours of dredging through 200 page threads of forum posts.)

There are two non-standard but semi-prevalent methods that may work depending on your make and model (and why recovery isn't working in the first place).

  1. Some phones actually respond to fastboot reboot recovery. This is quite natural given adb reboot recovery, but unfortunately is non-standard. I found lots of people suggesting this method so I offer it here in the hopes that it works for some, but it didn't for me.

  2. Some phones will actually let you book into an image via fastboot without flashing it. This will allow you to load a recovery image without needing to reboot the phone at all. You need a copy of the recovery image on your computer, but running fastboot boot image.img should do the trick. I was able to load up TWRP using this method.

  • That's interesting, thank you. I wonder what image.img you used? On a HTC One M8S I was unable to use some twrp.img, for example. The device rdebooted, but to the default bootloader (that hung up due to a missing system), it seems.
    – BurninLeo
    May 5, 2019 at 11:03
  • 1
    In case someone is looking for a way to get from fastboot to recovery on HTC One M8S, there is a path in the fastboot menu: (depending on the starting point) RADUMP2USB -> HBOOT (must not find a valid img file on the SD card) -> RECOVERY.
    – BurninLeo
    May 5, 2019 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .