I'm trying to fix a phone (LG G3 Stylus) that has been badly injured, so now the touchsreen doesn't work, and the only button that works is the volume-up one.

I need to backup some stuff (notes, calendar, contacts, and some apps data), so I was trying to add a Google account to sync the data.

Now I was going to do this by using an OTG cable, so I bought one (USB 3.0 A to USB C that has a USB C to micro usb adapter) to connect a mouse, but it didn't work.

Now I found this solution to control the phone with a Windows PC but it needs USB debugging activated.

Now that's the problem. How do I activate USB Debugging without the touchscreen. I read that I could get into recovery mode, but the power button doesn't work. What can I do?

EDIT 1: I found another app that allows me to control the device: Vysor. Now I still require USB Debugging enabled.

Now I tested the other OTG cable (usb 2.0) and it didn't work either. But I found something: USB debugging was already turned on, but for some reason I can't find it when I run adb devices.

Anyways there are some random touches so I am waiting until the screen unlocks.

  • Why an OTG USB-C adapter? AFAIK the LG G3 Stylus has just a micro USB port. If your mouse has an USB-C cable it is not a simple one (which may be that it does not work e.g. because the phone does not provide enough power).
    – Robert
    Commented Sep 6, 2018 at 17:46
  • No, I meant a USB A -> USB C cable and a USB C -> MicroUSB adapter, but I think the problem was that the cable was USB3.0 and the microusb port was 2.0
    – JCAguilera
    Commented Sep 6, 2018 at 18:28
  • What is "the other OTG cable"?
    – Dan Hulme
    Commented Sep 19, 2018 at 23:33
  • I meant that I have two OTG cables one is 3.0 and the other one is 2.0. The 3.0 is USB-A to USB-C and the 2.0 is USB-A to MicroUSB. The first one (3.0 USB A to USB C) came with a USB C to Micro USB adapter. I tested this cable with my tablet (with usb c) and it worked, but it didn't work in my personal phone (nor the phone I'm trying to fix) with the adapter. The other one (2.0 USB A to Micro USB) worked with my personal phone but not with the phone that I'm trying to fix.
    – JCAguilera
    Commented Sep 20, 2018 at 14:52
  • I read somewhere that not every OTG cable worked with every phone. So I'm just going to be trying other cables until one actually works.
    – JCAguilera
    Commented Sep 20, 2018 at 14:53

2 Answers 2


If you aren't seeing it in adb the try killing the adb server first with

    adb kill-server

If still nothing, you may be missing adb keys files.


Actually, we can Enable USB Debugging on Android with Broken Screen by OTG Adapter and USB Mouse or by Using ADB Commands and Fastboot.

  • Thanks I will try with OTG again. I think it didn't work the first time because the cable was 3.0 and the microusb port was 2.0. Now I tried a 2.0 OTG cable and it seems to work well with my phone.
    – JCAguilera
    Commented Sep 6, 2018 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .