Straight to the question:

To solve the issue I think I have two options:

  1. I read on XDA that the 4 files firmwares (service repair firmwares) are needed to fix the phone, but I couldn't find that type of firmware for my model, anyone has any idea how to get those?

  2. Downgrade: I'm on build 6 and there is only one update for build 6 released, that means I can't downgrade my phone to anything. I'd really like to fowngrade to build 5 firmwares, any way around this?

Long story:

I use my phone very normally, minimal apps, no custom ROM and no root etc.

My phone is in very good condition, no damages, no drops, protective case and screen protector (I take good care of it).

I was watching YouTube then Wi-Fi suddenly disconnected and it just doesn't turn back on, the circle-status-bar icon just keeps rotating right next to the Wi-Fi toggle switch and it says: "Turning Wi-Fi On" (or similar, my phone is not in English).

When I reboot the phone, the wifi state is on (though it's not on) switching Airplane mode does not change Wi-Fi state. Toggling Wi-Fi icon from Quick Lunch menu (Notification Menu) switches the on state of Wi-Fi to off, toggling again, switches it to the "Turning Wi-Fi on" mode.

Here's what I've tried so far with no avail:

  1. Rebooting phone a couple of times.
  2. Resetting network settings (+resetting both sim-cards networks)
  3. Resetting all settings.
  4. Booting into stock recovery and wiping cache.
  5. Backing up my data, removing all accounts (to prevent anti-theft lock-down), booting into stock recovery and wiping data (factory reset).
  6. I tried adb shell, dmesg and I searched for "wifi" in the output, here's the result:

    Line 125: [ 1407.084890] I[0:WifiStateMachin: 5871] mif: LNK-TX(16): fc 
    eb 0b 00 07 00 1b 00 0a 50 02 01 c0 ff ff ff
    Line 347: [ 1445.061702]  [0:         mc_log: 2225] MobiCore mcd: d01|TZ 
    DB Utils: Wifi UID: 1010 Per user range: 100000 System UID: 1000
    Line 518: [ 1447.799328]  [3:         mc_log: 2225] MobiCore mcd: d01|TZ 
    DB Utils: Wifi UID: 1010 Per user range: 100000 System UID: 1000
  7. Redid number 5, but this time I removed SD card and both sim cards before factory reset.
  8. A website suggested to have all Wi-Fi devices turned off, I turned off my router.
  9. Tried a soft-reset on my phone in those first steps that I forgot to mention, a website said that it is the equivalent of removing the battery and re-plugging it for non-removable battery phones.
  10. I watched this video: https://www.youtube.com/watch?v=F2K6AhkN98Y and since I never use bluetooth, I never checked but now I did and it turns out, bluetooth doesn't turn on as well... hardware problem? When I toggle the BT switch, the toggle moves but doesn't change to blue color, when I press back to previous window then go back to BT setting window, the toggle is off.
  11. My phone already had the latest firmware, so I downloaded the same (latest) firmware from sammobile.com and flashed with AP mode from Odin 3.12.3 and I wiped cache and data (factory reset) from stock recovery.
  12. Turning BT on from *#7353# (Quick Test Menu) just shows" Bluetooth is being turned on Please Wait..." and it just hangs there.
  13. Installed TWRP with Odin, and installed a custom ROM https://forum.xda-developers.com/samsung-a-series/development/rom-resurrection-remix-rr-v6-unofficial-t3765542 with TWRP. Wi-Fi doesn't want to turn on.
  14. I even tried this custom ROM https://forum.xda-developers.com/samsung-a-series/development/rom-advanced-seven-v1-3-t3516980 it still didn't work.

Sources for my troubleshoots:






2 Answers 2


If the factory reset didn't work I would probably get it warrantied. It seems like a hardware issue.


After all the hard work, finally I was able to resolve the issue! It's unbelievable for me and I'm so happy. So for anyone having the same issue just follow along this answer to get your Wifi and Bluetooth back working again on your Samsung Galaxy A Series device. The method that I am going to explain has worked fine on my A5 2016 Dual Sim A510FD.

Before we begin I recommend you to check this link, it has some good info on how to resolve the issue if you're not interested in reinstalling your firmware as a first step. https://forums.androidcentral.com/samsung-galaxy-s4-active/294093-please-help-my-galaxy-s4-wont-let-me-enable-wi-fi.html

Finding the right firmware for your device

Samsung firmwares are of two types:

Type 1: They come in a zip file which will include a single tar.md5 file, this firmware type did not fix the problem, so if you downloaded this type of firmware, don't bother flashing.

Type 2: These are called Service Repair Firmwares and they contain 4 tar.md5 files and one .pit file, we will only need the former tar.md5 files.

Please see: What is the difference between Samsung 4 files(Repairing firmware) and Single firmware file for flashing?

Now, the Type 2 are really hard to find if you're not willing to pay any money for them, your best bet is to try https://www.sammobile.com or https://updato.com/ or search forums on https://forum.xda-developers.com for your device. If you still can't find them, then you have to make a request or ask someone you know to help you out.

Samsung has some tight security on the matter of FRP locks, thus, downgrading to a lower binary number is not going to be possible (even if you only flash AP and CSC and exclude BL and CP files with odin). Go to Settings -> About -> Software info and write down your build number, the first number is your binary number, for example if you're on A510FXXU6CRH2 which the binary number will be 6, you can't downgrade to A510FXXU5CRG3 since for the latter the binary number is 5. Find the correct firmware based on your location and choose firmwares with same or higher binary number.

Also don't forget to go to developer options and turn on OEM unlock, and remove all google and Samsung accounts from your device, to prevent getting locked out of your device.

Wiping your device, Installing new stock OS

Download Odin 3.12.3 from https://odindownload.com/ (This is the version that I used but I also had no problem flashing with 3.07 and 3.13.1.

At all steps of working with Odin, make sure Re-Partition option is NOT ticked.

Download the correct version of TWRP for your device and flash it using AP slot with Odin.

Power off your phone and hold Power, Vol Up and Home keys at the same time to boot into TWRP, click on Wipe, Advanced Wipe and wipe everything except Micro SD and USB OTG.

Reboot and hold Power, Vol Down and Home keys to boot into download mode, and flash the 4 files of your downloaded firmware with Odin.

Enjoy Wi-Fi/Bluetooth! :D

Update 1: I forgot to edit sooner, but this method only worked for some hours and then I lost Wifi and Bluetooth again

Update 2: It's been a year since I wrote this Q&A, I didn't have Wifi and Bluetooth for a year!!

But 2 months ago, I bought a new modem router for my apartment, some times during this period I realized Bluetooth was turned on, I didn't pay attention because I didn't want to waste time fiddling with it, I knew it was a lost cause, but after some time I realized Wifi also turned on by itself!

So now I've been using Wifi and Bluetooth for a solid month without any issues! I believe the problem was my old modem router which was a D-Link 2640U which is 9 years old! My suggestion for you is to get a new router!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .