1

My proximity sensor is broken, and, Whastapp turns the screen off during call/audio. Not even power button will turn it back on.

All "solutions" out there tell me to clean the sensor. Impossible here.

How to disable this completely ?

I've tried Xposed's Disable Sensor module, entirely disabling this sensor or mocking it's values. No results.

I thought about revoking a sensor usage permission for that app, but could not find a module that has such an option

I can't remember if the problem happens during phone calls, but if the fix could be extended to this area, great

Xperia Z3

3
  • Sorry. Didn't work. Even with "Sensors" restricted on whatsapp. Wish I could send a screenshot – Lucas BS Sep 10 '18 at 14:54
  • On second thoughts, you can try applying to system apps (you can select system apps from the drop down) and select phone ( I am assuming it is phone app that is related to proximity sensor). If that doesn't help apply to all system apps. Nothing more I can suggest – beeshyams Sep 10 '18 at 21:23
1

Searching all over the web tonight 1/22/21 looking for an answer on how to fix this and found NOTHING. So with trial and error and a little ingenuity I developed my own solution which worked.

  1. Turn on airplane mode while the black error screen for in call is opened up on your phone.
  2. After the first beep notifying you the the call is losing connection the screen/app realizes it's error and reverts back to the normal state. In call screen will now be normal.
  3. Turn off airplane mode immediately after the in call screen is remedied so you do not lose your call.
  4. You're welcome 🙏
1
  • It's amazing how they allow this kind of problem in 2021... Android is so limited. – Lucas BS Jan 24 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.